Scan the garden for weeds

Hi there, I have set the weed scan using your “scan the garden for weeds” instructions Scan the Garden for Weeds | FarmBot Software Documentation and all works fine except for the fact that I cannot “view the results in the farm designer” when scaning as shown in “Step 4: Scan the Garden”. I have made sure to toggle the camera view area to ON. I must be missing something but I just can´t figure out what that is. Thanks and regards from Argentina!!

You can view the results on the weeds panel:
image

Please let us know if you still need help finding it.

Thanks Rick for your fast reply. According to “Step 4: Scan the Garden” what I should see is Fig 1 (attached) but what I actually see is Fig 2 (attached). What is it I am missing here? Thanks Cristian
Fig 1
Fig 2

@Cristian If I am understanding the issue:

  • Your device is able to detect weeds already and is populating weeds in the WEEDS panel.
  • You are not seeing any photos on the map.

Please let me know if I am misunderstanding the situation. The FarmBot Web App will filter (not show) photos from the map for a variety of reasons:

  • (very common) Z height must match same Z-height used for calibration. Do not zoom in or take photos at different heights.
  • (very common) Photo resolution must match the resolution used for camera calibration. Do not change camera resolution after calibrating.
  • Map photo layer must be on
  • Must be within range of the current date filter settings if any/enabled. (unlikely in your case)
  • Photo must not be marked as hidden (unlikely in your case)

You can click the “eye” icon in photo panel to see an explanation of why your photo did not appear on the map:

image


Other Screenshots:

image


image

Thanks Rick for your answer.

In response to your first two questions:

  • Your device is able to detect weeds already and is populating weeds in the WEEDS panel*

    NO, IT IS NOT, AS SEEN IN THE IMAGE. Please note that there also is a "plant detection ERROR shown at the top left, and I don´t know if this has something to do.

  • You are not seeing any photos on the map*. RIGHT. NO PHOTOS SHOWN IN THE MAP

Re the possible reasons you mention as of why the app may be filtering (not showing) photos, the only thing I can find that is different from what you mention is the list in the “eye” icon which shows the following settings:

Once again thanks for your help

Regards
Cristian

@Cristian Please run the scan again, but this time:

  • Take the photo at exactly the same Z height you used when you calibrated your camera.
  • Change your camera resolution back to the resolution you used to calibrate. You can change your resolution in the “CAMERA SETTINGS” panel:

image

If you don’t remember the original calibration height or the original camera resolution, consider re-calibrating your camera. Please also note that FarmBot works best when taking photos at a Z height of 0- performing image processing at non-zero Z depths is an advanced setting that we don’t recommend.