Sequences not running properly

I’m having a lot of issues with odd behavior when running sequences. Many of my sequences begin with a move up 100 steps if z > 100, followed by FIND HOME. FB will move up 100, then perform HOME Z, followed by HOME Y, and then stop with the following error:

Failed to execute rpc_request: “sequence error: %Farmbot.CeleryScript.Error{context: nil, message: “Movement failed: unhandled echo: R04 Q48”}”

If I run the sequence a second time it skips the move up since z < 100, performs HOME Z, followed by HOME Y, followed by HOME X, and then completes running the rest of the sequence.

Troubleshooting would be the appropriate category to post troubleshooting questions. I’ve moved it over there.

Thanks, mdingena.

you should post a screenshot of you’re sequence, that would be very helpful :slight_smile:

I’m still having this problem. The failure occurs when the FIND HOME command runs. It occurs after HOME Y initiates movement. Do these error codes have any meaning?

Is it an error code like this?

If so check this link out!

you can correspond the numbers to the chart n the link to get an idea of what and where the issue is.

Yes, I’m seeing a lot of “R08 F12 Q26” and “R04 Q26” messages.

So R08 is command echo, and F12 is HOME Y, which is when I see the error occurring.

The failure messages are always “R04 Q26”. Any idea what Q26 is? I see queue number, but that doesn’t help me identify the problem.

I see a lot of the following errors, all ending with unhandled echo: R04 Q26:

Failed to execute move_absolute
Failed to execute execute
Failed to execute sequence
Failed to execute rpc_request

Hmm ok so, R04 seems to be an issue when the FB is running the command, is there a particular place that this error comes up at within the sequence? it seems that the error is happening with a move command based on the error you provided.

with the Q26 code. im not exactly sure. it says Queue number but i dont have a clue wat it could be queueing up.

@connor might have a better answer for you on this one.

The error occurs when I execute FIND HOME in a sequence. Normally, when FIND HOME is executed in a sequence Farmbot performs a HOME Z, followed by HOME Y, and ends with HOME X. The error occurs after HOME Y is executed. The HOME Y command completes but HOME X never happens.

This happens in every sequence that begins with executing FIND HOME. It happens when a sequence calls another sequence that begins with FIND HOME. Rerunning the sequence is almost always successful.

The queue number is used by the firmware to associate all responses with the relevant command.

Does splitting the find home command into three commands to find home for each axis individually alleviate the issue?

Well now that’s an idea…

Sure enough, that worked. So it looks like there’s some kind of defect in FIND HOME with FIND ALL selected.

1 Like

Here’s a video showing this happening for mine as well. Running Find Home all stops running after the Y sequence, X never starts. However, when I find home or re-run the sequence after its reached this state, you can hear Z and Y home correctly, then X will start. Curiously, the Find Home action at the end of the same sequence always seems to run correctly.