Size in Farm Designer vs True Size

My calibration must have been slightly off when my Genesis 1.5 XL was originally set up six months ago.

The true size of my bed is: X = 4450 // Y = 2950

but Farm Designer shows: X = 4226 // Y = 2729 when my FB is fully extended to the top right corner.

So, if a plant is shown in Farm Designer as being located at (100,100,0), it is in fact at (105,108,0) in real life.

Is it possible to adjust my Farmbot calibration / Farm Designer so that true measurements are shown without losing the position of my 179 plants (so that they can continue to be watered in the right place)?

The farm designer (grid area) represents the coordinates that the tool head can travel to, which will be a smaller area than the actual bed. Though that discrepancy doesn’t sound like what you are describing.

It sounds like you may have a slight scaling problem (5% to 8%) depending on the axis, where the FarmBot is moving a different distance than it should be. This could be partially attributable to belt stretch, but I don’t think the belts can stretch more than 1 or 2% before the tension would be so great your motors would probably stall, so I don’t imagine that’s the whole of the issue.

As a workaround you can adjust the STEPS PER MM value for X and Y, which will allow you to keep working with the plants currently in the garden.

1 Like

Hi @roryaronson. Many thanks for having taken the time to respond. I know that you guys are super busy and it is really appreciated.

1 Like

@roryaronson I have just tried to reduce the STEPS PER MM from 5 to 4.7 but don’t seem to be able to do so (Farm Designer reverts back to 5 as soon as I leave the field). It doesn’t seem to like decimals and I am now not sure how to apply your suggestion?

Many thanks!

Ah shoot, I forgot about that limitation. STEPS PER MM indeed currently must be a whole number. Hmmm I’m not sure what else can be done.

How did this issue arise? Did you manually plant things in the garden with a measuring tape, add the plants to the map according to your measurements, and now you’re realizing that FarmBot is moving a scaled distance instead of the exact distance?

The only things that determine how far FarmBot moves in real life are the factors listed in the equations here:, which should be constant, though as mentioned previously, belt stretch can have a minor effect on belt pitch.

Hi @roryaronson, To answer your questions:

  1. We plant our veggies using a quick water jet from the Farmbot to indicate the exact position where each seed needs to go according to Farm Designer

  2. The calibration issue became apparent last week when I installed a replacement USB camera (the original was defective) and tried to stitch pictures for the first time. The stitching was not very good. In the following thread (How to adjust “stitching” to get a better FB selfie), @jrwaters suggested that I should make sure that moving 100mm in Farm Designer resulted in an actual move of 100mm. That’s when I realised that I have a problem

  3. Like you, I don’t think that belt stretch is an issue as the error margin is in the range 5-8%

Not being able to stitch properly is not the end of the world but it would be nice if we had a good method to calibrate the machine as I am not sure how effective weeding is going to be if chunks of the vegetable patch are missing from the pictures.

To ensure full photo coverage of the garden bed, you can have your FarmBot take photos closer together so that there is sufficient overlap. It wi just take a bit longer for a full scan because you’ll need to take more photos overall.

For movements, do you have always power motors set to ON? I know sometimes the cable carrier can act a bit like a spring causing the FarmBot to be pushed around a small distance once the power is removed.

If you issue a movement of 1000mm, does it move 1050 - 1080?

1 Like

Hi @roryaronson: Thanks for having taken the time to help.

As things stand, I have solved the issue. Unfortunately, I am not exactly sure how and cannot share a a solution with the community. I ended up dismantling and reassembling all the belts, rearranging the cables in the carriers and basically rearranging and tightening everything that could be rearranged and tightened…

1 Like

:thinking: haha welp, glad to hear the issue is solved! It’s funny how these things work out sometimes…

1 Like