Stall detection with FarmBot Express is still a work in progress

FarmBot Express and Express XL customers,

By now most if not all of you have received your order and have started setting up your new FarmBot. While your hardware is 100% ready to go, our software to support it is still being finalized. Here is the good news: right out of the box you should be able to boot your FarmBot up, connect it to the internet and your web account, and begin using it to plant seeds, water, weed, and do FarmBot’s usual tasks.

What’s still in-progress is support for the stall detection capabilities of the new stepper motor drivers included with your electronics board. Because stall detection is not yet fully supported by our firmware, your FarmBot will not yet be able to automatically calibrate its axes, automatically find the home position, or detect when it has stalled. For now, the setting to enable stall detection should be disabled in your web app account.

In lieu of using these automated features, you can manually enter axis length values on the device settings page and also use the SET ZERO buttons to manually set the home position.

Again, your FarmBot will work just fine and be able to take care of a garden even without stall detection enabled.

That being said, it is our team’s priority right now to finalize support for stall detection so we can unlock your FarmBot’s full potential. When the new firmware is ready, we’ll send out an announcement.

We thank you for your patience as we work hard to deliver 100% open-source hardware and software. If you have any questions, feel free to reach out. Thank you!


Are limit switches verboten?

@aronrubin That’s a good question. On previous models, advanced users would add aftermarket limit switches to their devices. We haven’t seen anyone do this since the v1.2 days, but it might be possible. Farmduino Express does expose pins for it and the firmware still supports the use of limit switches, but we’ve not tried it. We would be interested to see how it works out for you.

I will pick up these IP67 limit switches and give it a try:


I added limit switches to my Farmbot Express XL kit but find that any axis I have limit switches enabled for no longer tracks its own motion. Is there something buried in the software that assumes rotary encoders if limit switches are enabled?

1 Like

Have you tried enabling INVERT LIMIT SWITCHES?

Yes, I have that enabled as my limit switches are normally closed. Limit detection actually seems to work just fine but the farmbot doesn’t track its motion away from the limits at all and also moves extremely slowly all the time (not just when finding home).

1 Like

I was just about to add my X-axis switch but I guess I will wait. I also anticipated normally-closed as people have found that more reliable on 3d printers. Perhaps even if the UI has an invert option, the firmware tracking code expects normally open.

Both links are dead, could you please update them?


thanks for that hint, I’ve updated both links to the newest version of the docs (v10).
Feels a bit dirty to edit Rorys post :neutral_face: