Starting sequence but not finishing it


We’ve just been working outside (Not a good idea with this cold weather here…) But we found out that the FB starts the sequence but after the first movement it stops instead of performing the other movements. I’ve tried this sequence:

The result was that it moved the Y-axis and after that it stopped. It didn’t perform the Z-movement nor the X-movement after the wait.

After that I tried this sequence I made a few weeks ago:

And the FB moved like I would expect. It first moved to the 50,60 point and after that it went to home.

I hope someone can tell us why it isn’t performing the whole sequence.

I’m guessing because the movements in the first sequence are bigger and fall outside the wait time. There is still an issue that the sequence doesn’t wait enough before starting the next movement or step in sequence. Fix is in progress.

Another thing to try since you are using relative movements in your sequence: Try to move the bot using the jog buttons on the controls page the relative amounts you have in the sequence to make sure the bot can successfully move to the location.

Was this issue fixed in 3.1.6?

I have found that my FB fails to do some of the most simple of sequences: mount watering tool, water the entire length of my bed (~8m at speed 100), dismount tool.

Depending on what steps I remove or modify, the FB will do repeatable errors (not turn on the solenoid or skip/combine motion steps). What is odd is that if I simplify the sequence to only water and not mount/dismount the tool, the sequence will complete successfully. As I add in additional motion steps for mounting/dismounting, the errors start reappearing. Adding the mount/dismount as separate sequences to be called at the beginning and end of the sequence does not appear to fix anything. Is the movement timeout an absolute (i.e. additive over all movement actions in the sequence) or separate for each action?

1 Like