Static IPv4 address for Ethernet (wired) via Configurator AP won't stick

I’m using FBOS 6.4.11 from staging branch.

Not a biggie for me, but curious to know “what I’m doing wrong” in Configurator :blush:

The eth0 address ends up being DHCP-ed from my router (Apple AirPort Extreme)
My other very basic Nerves-based RPi3 happily uses a static IPv4 address with same physical router.

I’ve only lightly tested static ip addresses. What is the result you see? does it simply just never connect?

On boot after Configuration eth0 does get an IPv4 address and default gateway, etc. so it connects up to the WebApp Ok.

Just that, as I did mention, that address has been DHCP-ed from the router (which means I have to go ping-ing and ARP-ing around to find it ! (instead of booting my old MacBook Pro and running AirPort Utility))

For what it’s worth if you are looking for FarmBot on your network, it will be at farmbot-<4 unique-characters> just like when FarmBot is in configuration mode. For example: farmbot-eb30.

however I will investigate static ip settings not working.

mDNS is not my friend . . that RPi3 running farmbot_os is wired to the root router and my Windows 10 and Ubuntu machines use only WiFi (extended). Apparently not many routers do UDP multicast over WiFi because it’s quite complicated (Group Keys, etc). I’ve bought Apple because they love Bonjour, but I’ve had limited success.

Yes, if you can see the Bot connections into your Web-App, my machine name is Farmbot-f390 (using that native name that you described)

Hi @connor
I suspect I’ve found a source key-name issue underlying this issue :slight_smile:

FBOS Configurator and storage seems to use ipv4_method instead of ipv4_address_method.
I searched Nerves-Project/nerves_network for ipv4_method and came up empty.


Good catch! i’ll update that

Just noticed that you’re getting organized towards another FBOS release . .
Did you need a new Issue or a PR for this ?

1 Like

I did a lot of looking for when my ports kept closing down on my router / switch. My Netgear router has come a long way from three network cards in an at box to a complete operating system with several kinds of port controls.

Farmbot is a server which requires packet / port control access from the outside. each returning packet from the server and to the server is identified. This allows me to put packet forwarding on the router. This only opens those ports for the returning packets that the farmbot server needs and closes the ports for all others. This maintains the firewall aspects of the router for all other packets.

It works fine and allows farmbot to do its thing as a server on an internal network.



We actually have a couple updates being worked on right now. I haven’t tackled this one yet, but mostly to avoid git merge conflicts than anything. I’ll probably get it just before v6.4.12 is pushed out the door.

Thanks @Albert . . the code fix that @connor plans to make will address my original post.

Not sure if I should start another thread, but I am having static IP probs, too…

  1. The FB is wired into a public school network.
  2. in the config setup (accesses via phone) I walk through the setup for Ethernet.
  3. I only enter the static IP, the mask and the gateway.
    After “Finish” the blue LED flashes for a few minutes.
    Eventually the config screen comes back with a “NXDomain” error…
    Any ideas?

Hi @Intelbotfarmer This is a bug I reported back in December as ([])
which is Presumably in @connor’s lengthy and fast-moving work queue :sweat:

With static IPv4 you’ll need to enter the address of your primary DNS NameServer (usually the router) and that’s what’s broken . . though in your case a nil nameserver in the configurator form will have the same results I believe.

Thanks for the info, John.
Yea, I read through this thread, but I figured the bug was fixed in this release…
So, the nameserver has to be either a valid address (url, ip) to an actual nameserver, or the text “nil” ?

Hi Tony,
There were 2 bugs I found in Advanced Network configuration for Static IPv4 address method.
One is already fixed and the other (that we’re discussing) is yet to be fixed.

In the Configurator, Network Advanced Settings, the Nameserver is a dotted-decimal IPv4 address.
By nil, I just meant by leaving that form field empty.

I had entered the static ip, the subnet mask and the gateway.
I had left all other fields blank or default.
This did not work… ( eventually returned to configurator screen)

For static IPv4 address setup, the only field you can leave “blank” is the Domain.