Sudenly no communication between Arduino and Raspberry pi

Hi everyone !

I’m a 29yo maths teacher in France, and not very good at programming !

Everything was working fine but I had several warnings the last 2 weeks saying “your firmware is not going to be supported anymore”.

And today… Nothing works anymore. I don’t get how to resolve this; I tried updating but nothing happened…

Can someone help me please >.<


@RickCarlino I boldly tagg you because I saw you help other people sorting similar issues :slight_smile:

@lemonnier_france This post does not have enough information for me to make a definitive diagnosis, but I am suspicious that a clean SD-card reflash could fix it. Have you tried to re-configurate on a fresh SD card yet?

Also, are there any modifications or special circumstances for your setup?

1 Like

Hello from France too,
We just plug back our bot (Genesis 1.3), he was offline for more than one full week. Before we unplugged it, everything worked fine.
Now we have error code 30 and Farmduino card need flash but all try to flash it fail :confused:. We also reflashed the raspberry SD card, later reboot farmbot, but it doesn’t change anything…

I still have this issue, the robot is unusable, this is really annoying.
How can I flash the firmware for a Farmduino v1.2A board ? Is there any way to flash it from a computer ? How to reset the software written in the board ?

Try completely removing power, waiting a few moments and retrying. Also check that there are no shorts anywhere. avrdude is the program responsible for writing firmware, but it looks like your arduino isn’t responding. Are there lights flashing on your farmduino board?

The bug happened after Farmbot was off for more than 1 week. I already tried to remove power for a moment and retry. I think that my Arduino isn’t responding too.
I have the +RED6 red led always on (I think it’s just about power source plugged).
I think the RX led blink one really short time when I press “Flash firmware” button. No more led flash. Tomorrow I will try again and give more information if it still fails.
I got one general question about the board : is it possible to flash any Ardunio Mega program (just to test) from a computer by connecting only the USB A cable (no 12V power source) ?

I finally managed to flash the card… I don’t understand why it didn’t work before.
To flash the map, I have:

  • Change environment: different wifi network (personal network instead of our school’s) and use a personal web app server.
  • Disconnected all motors and encoders
  • Create a new account on the new server
  • Used a FarmbotOS 8.2.3 fresh install
  • Used and configured normally farmbot, everything worked the first time

Now I need to bring back all electronics in the bot at school and hope it will still work…
@lemonnier_france do you still have your problem ?

1 Like

We did exactly that, took us a little time to find this solution (I always make my students search themselves).

Sorry for the long time I just came back from holidays !

Sorry that it took so long I log in with the project mail adress so I didn’t receive notifications of your comments !!

Anyway, that’s what we did too, everything works fine now. We did a reboot of the sd card with my computer last wednesday and it’s fine.
Here’s the procedure we used in french :smiley:

### Utilisateurs Windows

1. téléchargez et installez Etcher .
2. téléchargez la dernière version .
3. insérez une carte SD dans votre PC.
4. ouvrez Etcher et sélectionnez le .imgfichier que vous venez de télécharger.
5. sélectionnez votre carte SD.
6. Brûler.