Tool Verification always reads No Tool

Hello!

I’ve recently finished assembling my new Genesis 1.5 kit, and I’m having some trouble reading sensors on the UTM tools. I noticed that my tool verification sensor always reads 1 (No tool) whether a tool is attached or not.

I tried connecting the pogo pins (B and C) on the UTM with an alligator clip jumper and still read 1 (No tool). Out of curiosity, I measured the voltage across pins A and B and saw 0V which seemed odd, since A should be 5V and B should be GND.

I disconnected the UTM cable from the Farmduino and connected / measured the pins labeled for the UTM on the bottom of the Farmduino board. I noticed…

  • Tool verification reads 1 (No tool) when I connect pin C to pin B
  • Tool verification reads 1 (No tool) even when I connect pin C directly to GND.
  • The voltage across pins A and B is always 0V
  • The voltage across pins 5V and GND (the pins above A and B) always ready 5V

Everything else works just great – the servos all work, as do the rotary encoders, peripherals (lights, solenoid, vacuum), and camera.

My gut says that something might be wrong with my Farmduino. Does anyone have any advice for further debugging or troubleshooting?

Thanks!

TL;DR - My tool verification always reads No Tool, even when I connect pin C to GND on the Farmduino board directly.

1 Like

Well, I was just about to add a picture, when I noticed that there are jumpers in the photo on the Farm Bot shop

Looks like that was supposed to happen in pre-assembly? The electronics box in my kit definitely did not have these guys installed.

I’ll see if I have some little jumpers around and give that a try :slight_smile:

1 Like

Yep, that was it!

I added the five missing jumpers as shown:

Voltage across pogo pins A and B on the UTM was ~5V (as expected)

Tool verification works now :smiley: and the soil moisture sensor seems to work, too!

2 Likes

@mwisely thanks for sharing your incisive debugging here !! :sunny:

Thanks for sharing for sure. I have the exact same problem with my new Genesis 1.5 and the jumpers are also missing on my board. I was just getting ready to dive into the detailed troubleshooting and saw your post. Thank you for saving me a ton of time!

Thanks for reporting this @mwisely and @jimcowan. There should have been jumpers pre-installed, but they must have been missed in your kits. Glad you had some extras lying around.

Luckily if anyone else runs into this problem, the kits separately include jumper wires (specifically for a custom UTM pin mapping) which can be used to remedy this issue. I’ve updated the documentation here: https://genesis.farm.bot/v1.5/FarmBot-Genesis-V1.5/electronics#step-5-plug-in-the-utm-cable

I have connected jumpers on the board, but still UTM not working. I do not have jumper cables, can I use breadboard female to female cables?

Sure you can, provided that they’re nice and short :slight_smile:

The jumper cables provided with the new Genesis 1.5 kit are very long!.