Unable to Configure Farmbot - urgent


Alright so my assumption was correct that ntp was failing. This propagates in an SSL/TLS issue, because validating those certs requires an accurate clock, which due to failed NTP your device does not have. I will investigate more and let you know why it is happening.


Thanks Connor. That would be great!

I spoke to our IT guys again today and they think one possibility could be that after the configuration, it reboots, gets an IP address through DHCP then by the time they try to ping it, the raspberry pi has already reset to default again and is back ready to be configured. The SSL / clock issue would explain that behaviour but they were unable to pinpoint the reason for it.

The fact that I’ve previously had it working on the same port / cable / network and we can reach the ntp server from a computer seems strange to me but I am no expert!

Thanks again for your time. I appreciate it!




Did you have any luck debugging the clock issue?


Hi rick,

I was waiting on Connor to check it out for me. I have exhausted all possible leads at my end. I’ll be doing backflips if it gets fixed!

When I go into my farmbot, it is stuck trying to move. I don’t know if that has anything to do with it but I thought I’d mention it anyway.



Hi Guys,

I just tried the bare bones approach with everything disconnected except the raspberry pi and the farmduino. Still getting the {tls_alert, ‘record overflow’} error. Also tried it again on my phone hotspot. The error was different but I didn’t screenshot it. Something about the network not being connected after one minute and there were possible reasons like being out of wifi range, hardware issues etc. It is possible that my phone hotspot was no good as service is not particularly good in that area but I am confident that if it had of connected, it would have given me the same tls alert error message that it has given me previously.

I am hoping you guys can track down the problem. Have some rather anxious teachers who have based a whole unit around the farmbot.



Can you post the error from the phone hotspot? the tls_alert indicates your device is unable to set time from NTP. If your bot could connect to your mobile hot spot, it should not give you the same error.


Hi Connor,

Here is the screenshot that I get when trying to connect to my phone.



I had problems when I did a mobile hotspot, too. I was able to get connected to the web app and even do some basic tests (move the bot), but every now and again it would reset the configuration. I think mobile hotspots are flaky in general, and on e dropped I think FB reverts to the configuration screen…


Hi Guys,

I thought I would try a different approach and connect a normal Raspberry Pi with the standard operating system to the Ethernet cable attached to my farmbot.

I first set it up in my office and I was able to ping pool.ntp.org successfully. I then took it out to my farmbot and was also able to ping it there but the two IP addresses were totally different.

I just want to check with you to make sure that the following address in the screenshot is the one it should be trying to access ( I had to photoshop it as it is in full sun there). The .static.tpgi.com.au is something that wasn’t on it when I tried in my office and the numbers are totally different as well.

The network switch is located in a house that my school acquired and whilst the IT guys don’t think its any different, they are somewhat confused as to why the address would be so different.

Don’t know why this would be an issue as my farmbot was working previously on the same ethernet cable / port but who knows, there could be something in it.



That is a little weird. I suspect the different IP addresses are a normal thing since NTP is made to be pooled. IE depending on load, you might get a different IP at different times. There’s also an issue with Farmbot itself in that getting NTP is sort of a race. NTP protocol doesn’t support errors or timeouts so Farmbot has to make some “gueses” as to if time has been set or not. I might be able to make a couple changes to make this easier. I’ve seen this issue come from several folks living in Australia so i think maybe the NTP pool is just a slow connection.


Hi Connor,

Thanks for your reply.

Is there a way to see what the farmbot is doing while it’s booting up i.e seeing what IP it’s trying to get to etc?

If I hook up a monitor to the hdmi out on the raspberry pi, will I see anything? Does farmbot create any logs of its activity if it’s not connected to the internet?

As you can probably tell, I’m pulling out all the stops to get this thing going!



Hi Connor,

I just went and tried to run the configurator again, entering our own school ntp server in the field for the ntp server 1 and 2.

I also tried it with the google time server - ntp.google.com in both 1 and 2.

I tried the combinations of both. I was able to ping both of these time servers from the same ethernet cable as the farmbot is connected to.

Neither of those methods worked :frowning:

Still giving the tls_alert record overflow error message upon restart.

Hope this gives you more information to work with.



Hi connor,

I also hooked up a screen to the raspberry pi and tried a number of different methods - raspberry pi only, raspberry pi and farmduino only, raspberry pi with farmduino and camera.

I video taped the screen as best as I could. If that will help you, I can get the videos to you.

Here’s a screenshot.

Sorry to bombard you with information but I need this working ASAP.



I had a similar issue. However, it got resolved when I used my personal hotspot or an ethernet wire without any restrictions.


Hi Guys,

I downloaded the latest version of the farmbot OS that Connor uploaded to GitHub 2 days ago and using a 4G wifi hotspot, I was able to get it connected. That hadn’t worked with any other version of the os.

Using the new OS, I hooked it up to Ethernet and still having the same tls alert record overflow error.

I’m not sure whether its the farmbot OS or our ethernet settings but our IT guys assure me that it is totally open and not behind any sort of firewall.

I did try a different Raspberry Pi to see if it is a hardware issue but I couldn’t see the wifi network of the farmbot to be able to configure it.

I can see light at the end of the tunnel now, At least I know its not a farmbot harware issue!




I forgot to mention that when connected to the 4G wifi dongle, the farmbot kept on disconnecting and reconnecting every couple of seconds. 4G coverage in the area is not fantastic but I doubt that would cause it to disconnect and reconnect. Don’t know if that could be related to the ethernet issue.



Did you reboot/reflash the OS? I’ve experienced this a couple of times, rebooting or reflashing always helped.

Were there any logs that indicate that Farmbot really was disconnected, or did it just show Disconnected where usually Synced is?



No logs to say it was disconnected. I was basing it off it saying disconnected where sync usually is.

I will try to re-flash the firmware this morning to see if it makes any difference. I will do that with the latest version on git hub that I have just downloaded. I don’t think that version is different to the last one I downloaded but its now an official release so I’ll give it a go.



Hi Guys,

I am so very happy to report that my problem is solved!

I had our IT guys do a packet trace with our provider.

The IP was open but during configuration, the farmbot named itself my.farm.bot and it wasn’t on our exceptions list.

Sorry for wasting so much of your time. Our IT department was unaware that there was a firewall above their standard one.

Thanks again, particularly to Connor. Hopefully I will now have years of trouble free operation!



@markgregory8 :tada: Happy to hear it is working for you. Please let us know if you have any other issues.