Unable to find configurator after reset Update: appears to be power issue to RPi

I’ve had a fairly well working farmbot genesis 1.3 which only occasionally had issues with wifi connection.
I messed around with the wifi position over the last few days and changed the names of the APs to distinguish them which I then returned to their original names. I expected farmbot to reset and give me the usual farmbot ap from which to configure it from but this didn’t occur.

I have since tried different versions of farmbot OS (9.1.2, 10, latest one) to no avail,
I’ve changed the SD card to another one - still the same
I’ve checked the LEDs on the rasp pi 3 - only odd thing is that there is no red one lit but the green one does the usual expected blinking when starting up (I don’t think the red led ever worked - fwiw, it’s connected the arduino which is connected to mains power so I’d be surprised if it’s a power issue). I would assume if there wasn’t enough power to run then the green light wouldn’t be doing its intermittent flashing.

This is on a farmbot that has worked with no (major) issues for the last few months since I built it during lockdown.

Next steps I guess would be ethernet which I can do but I think I’ll have to create a special ssh login?
I tried to get something up on but nil worked (my network is

Any pointers would be great!

Thanks in advance

Hi @nikopol here are a couple of my thoughts

  • The FBOS Factory Reset Timer is long ( 5 days ) and also needs to be Enabled in the Web App
  • I would flash the newest FBOS ( v10.1.3 ) to a known good microSDHC
  • Check the Green LED on the RPi3B board as it boots up to see activity
  • The initial Configurator sets up its WiFi AP on
    While your browser is about to configure it, have another tab/window open on to watch for any problems
  • As always, there’s a magnificent troubleshooting guide here :slight_smile:
1 Like

Hi there, thanks for the rapid response.
Just to go over the points you made

  • That may explain why it didn’t reset after I changed the ap name but then surely after I wiped the SD card with a new FBOS then I assume it should have appeared then? I tried this four times to no avail.

  • Tried that and failed. That’s why I tried older versions from previous threads advice. Still no configuration coming up.

  • Green LED doing the expected booting flickering. No pattern noted

  • On when contacted to Ethernet? ( I can’t get any WiFi from it over the last day )

  • I’ve been thru it before posting. It didn’t have much regarding failure of the configuration WiFi to launch. I assume ssh is the best options for troubleshooting?

Which flashing app are you using ? To check whether the FBOS disk image is really being burned onto your microSDHC, you should try a new one fresh out of its wrapper.

Above comment still applies.

No. That IPv4 server address is only used on the WiFi Access Point for Configurator.

Best is subjective. To use SSH to your RPi3B in Configurator mode, you would have to have previously built your own Development image of FBOS and have flashed it and booted up on that. ( ‘chicken and egg’ situation )

Of course, once you’ve booted up Configurator on a Released version of FBOS you have a chance to add your own Public Key so that you can use SSH once FBOS comes up.

For fundamental troubleshooting like this, I prefer the old-school Serial Console connection available on the RPi3B. You need to have a 3.3V TTL to USB adapter device and cables . . ( not expensive ).

1 Like

@nikopol Usually, when folks flash an SD card and nothing comes up, it’s a sign that the wrong platform was selected when flashing the SD card. Are you certain you’ve selected the correct platform for your device?

When you select old versions of FBOS from the releases page:

  • rpi is for “Express” models (Example: farmbot-rpi-10.1.3.img)
  • rpi3 is for “Genesis” models (Example: farmbot-rpi3-10.1.3.img)

Another common problem is a confusing user interface in Balena Etcher (we’ve notified them about the confusion and future versions may be updated to avoid confusion):


In the screenshot above, the SD card write actually failed (and will not boot).

Do you think either could be the case?

You do not need to create an SSH login to use Ethernet, and I do not recommend SSH at all unless you are familiar with the Elixir programming language.

Some other tips I offer when folks are having configurator issues:

  • Avoid re-using configurator until issues are resolved. If you hit problems, re-flash the card to make sure you are starting over completely.
  • Avoid using the “UPDATE” button in the web app until the issue is resolved. Flashing on a fresh SD card can reset errors that linger between updates.
  • Don’t use static IPs unless you have a very good reason to do so. DHCP is a first-class citizen in FBOS and static setups are an edge case reserved for schools and other large institutions that have IT departments. Static IP setups are always more difficult to setup.
  • Be aware of the “AUTOMATIC FACTORY RESET” setting for your account, as it will cause your device to factory reset itself after a period of time (some users want this feature, other users do not)


Thanks for the help so far.

I’ve made progress but still stuck.Turns out the issue may be the arduino supplying insufficient power to the rapsberry pi

did all the reflashing etc but didn’t work. Took the rapsberry pi out as I wondered if there was a power issue - turns out the red led comes on when on normal power but doesn’t when in situ in the farmbot. Could also see the wifi point when not attached.
There was a thunderstorm recently which was why I was wondering if the wireless component had fried on the pi.

Checked all the connections of power and that seemed to be normal - can run a halogen light from the power supply (mains) so seems that’s not the cause.

I guess now I need to figure out why the arduino won’t give enough power to the board - it’s not the cable powering the pi as I checked that. The fuse on the arduino also seems intact.

The odd thing is why the farmbot is getting enough power to get the green led flashing - there is power just not enough…

TL:DR - not a farmbot OS issue, it’s a power to the raspi that’s the issue

1 Like

Can you measure the supply voltage on the raspberry? Easiest way is to measure on Pin 2 against ground. I’ve had similar issues with my 3rd party board (MKS Gen1.4) and came to the conclusion, that the internal voltage regulator (Step down module?) was not able to supply stable 5V when the raspberry was running so I’m now using an external stepdown module (LM2596) that supplies the raspberry.

I’ll buy a multimeter tomorrow and check. I’m still a bit baffled why after months of working with no issue it’s suddenly no longer getting enough Juice but that’s clearly what’s caused the mess.

1 Like

Sorry - life got busy. Finally have multimeter. Where is the pin2? Is it on the farmduino or the rpi? If anyone has a photo that would help (I’m really not that good with this area).

It is on the pin header of your Raspberry Pi. Here is a pinout of that header, where the pin number is right next to each pin. You need to measure 5V (Red pins in that picture) against ground. Make sure that you do not touch multiple pins at the same time with your probe to prevent short circuits or similar damage. Safest way is measuring pin 2(5V) against Pin 39(Ground). You can also use the metal case of the usb slots as ground.

1 Like

Thanks for that. Got a new baby so put the bot on the backburner for a while!

  • Rpi when plugged in to normal usb input =5v
  • when plugged into farmduino also now 5v ?! - complete change from while back.
  • was about to get it working again (connected it to the wifi) then
  • everything stopped. Now no power going to the farmduino.

I’m thinking that the power supply is the issue not outputing the correct amount consistenty

1 Like

Tried the multimeter on the 4 prong (not sure what was which but tried them all) and no output at all.
Tried a different power plug and still the same, so I guess I’ve got a dead power supply?

What I don’t understand is whether that has been the cause of my issues all along or not. Is a power supply usually binary (works or not) or can it output a certain output one day, a normal amount another then nothing a few hours later?

Any insight helpful! :slight_smile:

I must have done something wrong somewhere - I checked the power to the water pump as a hunch and that is getting 5v (which I assume comes from the farmduino board?!) Nothing is lit up on the farmduino board so I’m completely at a loss… I must have not tested the 4-pin correctly maybe? But it still doesn’t explain why nothing electronic works or lights up. I’m at a total loss :frowning:

Genesis V1.3 . . that’s a 12V power supply ? Peripherals should be getting the full 12VDC switched.
Seems still to be a power supply issue (?)