Upgraded farmduino to 1.5 from 1.4 now no motors working?

Hi
Recently I experienced an issue with my farmduino V1.4, caused by myself, plugging in a stepper driver backwards and rather than replacing the board with the 1.4, I ordered and received a Farmduino V1.5, which I thought would just be a drop in upgrade.
After fitting the V1.5 this morning, I now have no motors working on my device page of the farmbot webpage. I think I can hear some quiet clicking coming from the motors, but no movement. In my logs it says axis timed out.
I’m not sure where to start with this.

@dmbgo, you’ve probably checked this, but just in case . . make sure that your Raspberry Pi is on FBOS v9.2.1 and that you’ve selected the correct firmware, e.g. here’s my Device page ( also recently upgraded Farmduino from v1.4 to v1.5 . . though no steppers attached yet ) :slight_smile:

If you’ve changed many hardware parameters over time, you may need to go to Danger Zone and RESET HARDWARE PARAMETER DEFAULTS as a starting point.

2 Likes

I think you may have a possible answer with the firmware part. I remember selecting 1.4 because I had built a V1.4 Farmbot. Now that you mention it, it makes sense that this is now a V1.5.
I’ll change it and let you know the result.
Thanks
Dave

1 Like

Sadly, despite changing to the correct firmware for the farmduino 1.5, the problem isn’t resolved.
When I manually move the axis, the position is updated and shows the correct amount of movement. For example, if I move the Y axis to the 0 position, then set that position as 0, by selecting “zero Y” in the Device tab, looking back at the Controls tab, I can see that the Y axis is now showing “0”.
If I then manually move the Y axis to about 500mm from zero, it shows that Y is now at 506mm, which is what I would expect.
However there is still no actual motor movement. If, starting from 0 position, with the axis zeroed, I use the controls tab of the browser to move the Y axis to 100 and press “Go”, the motor clicks slightly, there is no noticeable movement and the position updates from “0” to “-0.7mm”. There is an error though. Something along the lines of “absolute movement failed”.

I had another (briefly) hope filled moment, when I thought that perhaps I had somehow plugged the motor connectors into the wrong positions, so that for example I had motor X and encoder Y connected to the controller, instead of motor Y and encoder Y.
I tested this by selecting “Always power motors” in the device tab, for the Y axis only. I then went out and checked. The Y motor was indeed locked in position.

This, I think given that it all worked before and is affecting all motors, I am disregarding wiring issues etc, so it must be something in here:

Almost each of those settings are set to a really high value. I’m wondering how they could have ever worked with such astronomical speed values. Were there any “DIP-switches” set on your old farmduino 1.4? Since you are using 10 STEPS PER MM and only 1 MICROSTEPS PER STEP for X- and Y-Axis it seems like you had 1/2 stepping on your old A4988 stepper drivers. Moving 2400 mm/s is really out of the roof, you would travel from one end of the X-axis to the other in like 1,5sec! :crazy_face: :rocket:
Also that weird Z-axis speeds are nothing you can work with. I recommend to reset the values as John wrote earlier:

1 Like

@dmbgo, now my curiosity is piqued :slight_smile:

I’ll PM you . .

|edit| Oops @Ascend got there first :-} . . I’ll PM anyways.

|next edit| Maybe my intended PM didn’t work . . Summary : I’m near enough to visit ( provided we obey the current 4.0m^2 per-person sep. rule. BGO and region are my favourite districts.

|another edit| I can bring my new Farmduino v1.5 with me to help find your solution.

1 Like

Thanks JSimmonds and Ascend. I’m off to bed now, but I’ll look again in the morning. I do remember thinking that the axis travel values seemed high with the old board, and yes JSimmonds there were some dip switches on the old 1.4 board, I’ll tell you what they were in the Am.
Goodnight
Dave

I’ve had a look this morning at both the old Farmduino 1.4 and the Farmbot.
The old Farmduino has dippers above the stepper drivers and they are set with switch 1 on and 2 and 3 off. I haven’t had a look to see what this setting is yet.
I’ve now tried the farmbot with what I think are conservative motor settings they are now as shown in the screenshot below.
I’ve also done a factory reset. The motors now try to move when I ask them to, but go backwards and forwards, without really getting anywhere.

Hint to a weary poster :slight_smile: use the ‘@’ prefix to the member handle to have them automatically notified :auto_rickshaw:

Here you can see the microstepping table in the software docs.
Only having MS3 activated, there will be no microstepping effect on the old “red” a4988 stepper drivers. Looks like your configuration didn’t fit with your old 1.4 Farmduino board which should have caused false travel distances and moving errors detected by the encoder.

I didn’t see your encoder settings yet, but I’m pretty sure that this is caused by wrong STEPS PER MM values. Looks like you changed those values after the factory reset because the default values are 5,5,25. So your encoder expects your axis to move less distance than it actually does and throws moving errors. The device wants to reposition but that also does not work if the motor always moves farther than the firmware wants to.

You can try this to check if thats the issue:

  • Disable the encoder of the X-axis
  • Move the X-axis in the controls tab for a certain distance, like 100mm
  • Measure the traveled distance, if the axis has traveled 200mm then divide your steps per mm by 2.
  • You will probably run fine with the default values 5,5,25.

If your axis still does not move with encoders disabled, you can try to increase the MOTOR CURRENT value in steps of 50 to a max of 800. NEMA 17 motors usually run between 0,7A to 1,1A for TMC2130, so the 0,6A might be a bit low for the bot. Here are more information, just for reference: https://learn.watterott.com/silentstepstick/faq/

1 Like

Thanks for the tip @jsimmonds
@ascend you were right, I found and fixed that issue this morning, here is a quick breakdown of what was wrong:
1/ I thought I had followed jsimmonds and your advice initially, but must have overlooked something, so I did the factory reset again.
2/ My Axis lengths were then wrong because of the change in the number of steps per mm etc, so I recalculated and applied them.
3/ I had to reconfigure my tool locations, since the new axis lengths were slightly different to the old (a mm or 2).
4/ I had to invert the direction of one of the X axis motors, since for some reason it was going the wrong way after a factory reset and fighting with the other motor.

Had I been more patient, I would have fixed things based on your answer, but it must be gratifying to know that you were right :slight_smile:
Dave

2 Likes

That sounds great @dmbgo , I’m glad you got it back running. Let us know if anything does not work as expected. Happy gardening! :seedling: :robot:

1 Like