What do I do to fix Network Quality?

My Wifi signal strength is at a steady 50%. It’s green, so I assume that means it’s okay.

My farmbot will connect to the message broker for a few seconds, or a minute, and then disconnect. Pings received are about 21% successful. What do I do to fix this? It seems it works, just that it will not work reliably enough to do anything.

Hi @Mat there are plenty of other posts in this forum about exactly this ( fair WiFi strength and resultant loss of reliability for the bot <=> AMQP/MQTT link )

These are my suggestions :slight_smile:

  • Install a WiFi “range extender” to boost the signal power at the bot.
  • Replace wireless with a wired Ethernet ( shielded CAT 5 ) cable

About that WiFi strength reported by the FarmBot OS : I’ve recently discovered that the number reported only updates very occasionally. I’m working on a fix for this which I’ll then submit to the FarmBot Dev. Team to assess.

3 Likes

@jsimmonds Thanks, I didn’t understand the other posts were relevant because I was trusting the signal strength indicator. What you’ve said clears that up a lot. I appreciate it.

Good.

Also, I have a fix for CPU usage value in final testing. CPU usage ( Scheduler usage ) is reporting lower than actual by 2x :lying_face: i.e. reported 40% is actually 80%

2 Likes

@Mat A lot of users have been confused by the green WiFi icon and we are going to deploy a less confusing fix today. Sorry for any confusion. In the current app (Before 3 AUG 2020) green just means “the WiFi is up”. That doesn’t mean it’s actually a good connection, though. It just means that it has WiFi access.

The new UI will go red when the connection drops below 68%. The reason we chose that cutoff is based on real-world customer support requests. I have never seen a customer successfully get a device running with less than 68% strength. As @jsimmonds mentioned you will need to purchase a WiFi range extender or switch the device to Ethernet. Ethernet is only available on Genesis models.

@Mat The update has been deployed to production:

image

Even after installing a wi-fi boost, I was still not 100% reliable (probably distance and objects in the way), so I purchased a tp-link POE (power over ethernet) adapters so now I have an actual cat 5 connection which has solved it. You just need a 120V outlet close by and you have to make sure the both ends are on the same side of the breaker panel.

2 Likes

Interesting idea @ldgaley- so you used something like this?

image

Great suggestion- we will pass this along as an option for customers with unique setup requirements.

The one I use is the TL-PA4010 KIT, it’s a bit cheaper unless you need the 120V plug. One is installed in the house next to my router and the other is on the outlet that powers the farmbot. You do have to make sure they are both on the same leg of the house breaker box and they cannot be plugged into a strip (any filtering or transformer will block the ethernet signal). They have worked great for me.

2 Likes

@ldgaley I’m curious about the distance between the house router and the bot ?

Just being picky, but that solution isn’t technically PoE, it’s more EoP :slight_smile:

You are correct- ethernet over power- I’m just used to the ancronym POE. My main wireless router is in the front of the house, about 80 feet from the farmbot and thru 50 feet of house. I have a repeater in the middle of the house about 60 feet from the farmbot. The farmbot is inside a wood/plastic greenhouse. The farmbot detects the wi-fi just fine but we noticed it disconnecting many times during the day when we were testing and it was annoying enough that we tried the ethernet repeaters and found them to be much more reliable.

It’s a fine solution ( while your bot is “on the grid” ) :wink: