Why does this machine fail so much?

wow. unfortunately i don’t know how to do any of that. LOL

I had it running nicely the last couple days but this morning starting at 07:56 to 09:27 it has rebooted 31 times, flashed the firmware 4 times and has failed in three attempts i’ve tried to water my garden just now. super frustrating as i do not know why.

i saw the error log pop up once and it was so brief i couldn’t even screen shot it. nor do i know where to find it logged nor would i know what it meant anyhow.

the only way i’m aware to interrupt this reboot cycle is to E-stop it for an as yet undetermined amount of time?

oh! you’re programming these in sequences?

ok well pausing it for about 15 minutes seems to have interrupted the reboot cycle. then trying to run a watering sequence that has worked many many times it got about 11 plants in and stopped, spitting this shorter error code which means nothing to me.

Error

{:noproc, {GenServer, :call, [FarmbotOS.Firmware.UARTCore, {:start_job, %FarmbotOS.Firmware.GCode{string: “F41 P8.00 V1.00 M0.00”, command: :F41, params: [P: 8, V: 1, M: 0], echo: nil}}, 600000]}}

and now after pausing and trying to research this - not very successfully - I unpaused and ran a different, simpler watering sequence which got through about 25 repetitions then failed with a much larger error code.

seems today nothing at all is working like it has for the last week or so. very frustrating, feels like a huge waste of money and time i didn’t have available to water in the first place

now I run it to the end of x and back, no problem
run it to the end of y and back, no problem
send run to the end of x again - movement failed,
send run to the end of x again, no response
send run to the end of x again, no response
send run to the end of x again, movement failed,
reboot

idk what it is doing or why today. nothing has changed form yesterday when it was running fine except for the date and the time on the clock

after reboot and another firmware flash, send to the end of x - no problem.

return home - failed, reboot.

hi, i sent an unhappy email to the company. they think i have a faulty farmduino board. try contacting them

The FB team sent me a new board when I had similar issues. Been much better since.

I have express XL as well. Same wifi issues so I put in a wifi relay box and took ethernet out of that. The cable caddy tabs to just pop off with a bit of firm pressure, I used a flat head screw driver and then ran the cable in that.

Good luck

thank you for that info. I didn’t want to break them. the zip ties certainly get in the wat of smooth operation. i’m awaiting the new board myself.

omg I hope the new circuit board fixes this thing because at this point i hate it so much. it can’t even water three plants in a row without booting. yesterday it decided to run 1000mm back and forth with the water freely running. its bizarre and useless and wastes SO MUCH of my time.