WI FI configuration for school environment


#1

Greetings,

I have a new Farmbot 1.4 which we are using in a high school environment. Farmbot is giving me an error that says "FarmBot and the browser are both connected to the internet (or have been recently). Try rebooting FarmBot and refreshing the browser. If the issue persists, something may be preventing FarmBot from accessing the message broker (used to communicate with your web browser in real-time). If you are on a company or school network, a firewall may be blocking port 5672. (code 26)

I have contacted my network admin and he has requested the pi’s IP address (and mac address if possible) to allow it access to the port. I cannot figure out how to find either. Once this is figured out, are there other ports/sites ( have seen some referenced in other posts but would like a list) besides 5672?

Thanks for your help,
Pat


#2

Hello pat,
There is a thread from Connor in the FAQ section where you can find the ports that are needed.

You can find your Mac address in the configurator (step 2). At the page where you have the choice between WiFi and Ethernet you can click on a small i icon below the pictures.

The bot usually receives it’s IP via DHCP but you can set it in the configurator in step 4 (advanced settings).

Hope this helps :slightly_smiling_face:


#3

Ok, so static IP is the way to go. I thought there might be an “ipconfig” equivalent, but then again, if my admin is making a firewall rule then a static IP is better anyhow. My students are gone for the day, but I’ll sick them on this Monday. Thank you!