X axis issues need help

I am having issues with getting the FB to operate along the X-axis smoothly. I took some advice from the forum here and now it seems to be a bit worse.

At first, the problem along any run greater than 100mm (and occasionally even at that length) was that one side seemed to get tied up while the other side ran, causing it to be no longer perpendicular to itself. I have read here the accounts of others with similar issues and have now tried the following;

  1. the rails are perfectly aligned. I dremmeled the seam of the extrusions where they meet in the middle to remove some burrs that were tying up the wheels. That helped.

  2. I have adjusted the eccentric inserts on the wheels to play with lower wheel contact force.

2.5) I have adjusted belt tension.

  1. I adjusted the length of the horizontal gantry to see if there was a way to load the uprights differently, which did nothing.

  2. I lowered the speed from 800 to 400 with no luck.

  3. I adjusted the voltage on the stepper motor drivers to 1V and have tried some voltages in between (like 0.75V and 0.6V) with no improvement. In fact, the X0 motor is worse. Now, it does this jittery movement as it brings itself up to speed (whereas the other side doesnt), which means that it starts off not-perpendicular, and now the unit wont travel at all for the most part.

I have run out of ideas. Any advice would be greatly appreciated. Y and Z work fine.

Many Thanks,

At the very beginning, was your X axis having these issues, right off the bat?

and you only adjusted the stepper motor for the side that was lagging behind correct?

not for both of them?

the reason I ask is because it seems that one of your motors needs more voltage to keep up and stay parallel with the other side of the Z axis.

if this was happening when you first started up the farmbot for its first time then reset both of the screw that controls the stepper voltage back to its original position and then adjust the other driver (the one that deals with power to the motor that seems to be lagging) by increasing the voltage and that may solve the issue of lagging behind.

Thats good advice.

How do you know which stepper controller controls what? Its not labeled and I dont recall seeing it anywhere in the documentation.

Right now, I have the added problem of one of the motors doing this jittery/back-and-forth movement in the first split second or so, which leads to bad lagging compared to the other side which accelerates smoothly.

Hey @jonweisw
Could you please take a look at this thread -> X2 is doing nothing (connected to E0 on RAMPS)

Right there someone described the same symptoms of his motors and provided a short video. If your X2 motor acts similar, you also should try to swap your X2 driver with for example the X-axis driver. If this issue appears at the motor of the Y-axis your driver might be broken.

If you are not sure how the electronic board is built up, you can see on this site under step 4 where which motor is connected -> https://genesis.farmbot.io/docs/plug-everything-in

If you still have questions or don’t know exactly what you need to do, we can give you more detailed instructions any time :slight_smile:


Thanks SO much for he reply.

Yes, I followed that thread and it prompted me to switch the drivers as well with good result in that the jitteriness went away on the X-motor.

I havent tried Y or Z yet to see what the fallout will be there, but I suspect I will have to replace the driver (NBD).

In the meantime, I still can not get both sides of the machine to move much along the X-without binding up. What do you advise to troubleshoot this problem? I am hesitant to adjust the voltage on the drivers again unless that is best way to address this…

(BTW - I figured out the layout of the drivers by removing them sequentially and observing the loss of functionality associated with it. I didnt realize that that schematic was for the drivers although it probably pretty obvious)

Alright it sounds like this driver may be damaged. But we only know when you tried the axis where it’s used now.

Did you try to move the X-motors with loosen belts? Does X2 even move?
When you push the gantry slightly in X-direction, do you feel resistance at some point? It is just to check the mechanical part to make sure your x-axis moves smoothly (but I guess you tried that).

Adjusting the drivers seems to be more damaging than helping, but it would technically help I think (if the motor can’t deal with that movement electrically)
Maybe you can find out if this only occurs at the same places or if it can happen everywhere while accelerating.

All good advice and again, cant thank you enough for it…

The entire assembly moves easily along the entire 10’ of tracks without power. I have the eccentric spacers on the wheels set for the least amount of force against the bottom (which seems to be the best setting for both X and Y axes - its the one where the mark on the spacer is facing squarely down). As I mentioned, I had been having a bit of trouble at the seam where the two extrusions butt up against each other, but I remedied that by deburring the edges some with a dremel. I would add that I think that if you supplied some dowel to fit in the holes in the two pieces of extrusion at that junction that that would be very useful as I suspect that this issue with the X-axis is going to be one that is a recurrent one. It would firm up that joint and prevent much disparity in terms of alignment.

So, the X-motors move with the belts loosened. I had been having jitteriness on one of them after adjusting the voltage. I swapped the drivers and the problem persisted on the same motor. I removed the motor and took it apart in the shop as much as I could. I removed the little wheel attached to the drive shaft underneath the removeable circuit board and thats as far as I could go. I put it all back together and for some reason it work as good as it did before (the jitteriness went away). Meanwhile, the Y and Z axes move perfectly as well (with the drivers swapped from the X axis).

Ill add that it doesnt seem to get bound up in any particular area; sometimes it will sail past one point on the X-axis, and then on a repeat of the same trip it will get bound up. The rails are parallel to each other within 1/16".

I am left to think that the jitteriness was related to something temporary on the X motor.

So, here are my questions:

  1. X-Axis: Is it worth adjusting the voltage on the stepper drivers to try to overcome areas where it seems to get bound up? If so, how do you recommend doing this? I used a multimeter last time and adjusted the voltage between the potentiometer screw and one of the corner nodes to 1V, but the results were bad in terms of sound, quality, and jitteriness, so I backed off incrementally, stopping at 0.75V and 0.6V, without resolution. Instructions from you would be particularly useful here as the Pololu video doesnt make clear which node on the circuit board of the stepper driver is the ground reference. How do you recommend that I proceed?

  2. Most times, I get a “relative movement request failed” flag with any kind of movement, even though the unit moves appropriately. This occurs in all three axes. I have checked the wiring of the encoder harness and it seems correct. You should make clear that the it is the smaller black wire in the harness that gets used, not the larger one. Any ideas in this regard?

Many thanks,

You can safely use the negative screw on the green power block that fits into the RAMPS from the power supply. If you wired it up correctly it should be the black wire. This screw is easier to touch with the multimeter than those little nodes on the stepper drivers. You don’t want to accidentally slip off those…[quote=“jonweisw, post:7, topic:1838”]
You should make clear that the it is the smaller black wire in the harness that gets used, not the larger one.

Totally agree. For me, as non-electronics guy, it was a guess based on the fact there is a black wire right next to the red one and it had the same thickness as the other cables, while the ticker black cable at the other end of the harness just seemed ‘off’ and was completely omitted from the documentation. Should be mentioned as ‘not used’ just like the yellow wires are.

I used this video to measure my stepper drivers. This guy talks a lot so skip to about 8m 50s and he shows you how he measures the potentiometers.

As for how much Volts you should set it to, check out this answer.

Mdingena -

Thanks for the help.

Great re where to measure ground point. Shoulda thought of that before…

As far as voltages, I followed the advice on the thread that you supplied and tuned them up to 1.0V. Unfortunately, that was when the real problems began; the sound of the motor changed, it didnt move as effectively, and there was a jittery start before it got up to speed which allowed the other motor to advance out of sync, thereby causing a major bind-up situation…the problem I am trying to fix got worse! I will try it again today, perhaps a little more methodically, but I suspect this is going to be an ongoing problem for builders and one that will need to be addressed officially.

The advice given in that thread assumes you are using the motors from the Genesis pre-order kit. Other motors will have other needs.

having trouble with stuttering x axis I ran into a t-bolt problem. 6 had come loose at the vertical shaft , upper end and 4 were loose at the bottom. This was enough so that the vertical rail seemed to be dragging on one of the wheels. !!!

My error.



Ok - got it working great now.

It required turning the speed down to 600, and advancing it at progressively longer runs down the track. As I did that, I watched the X0 side where most of the binding problems seemed to be developing. Paying close attention to the motor shaft, I could see that when it was binding up, it wasnt because the shaft was spinning under the belt (ie, the belt was tight enough), but rather that it just neede more muscle. I progressively increased the voltage on that side to 1.0V and now it works great.

The big problem now is getting it to reliably go where it needs to go and getting it to be repetitive down to 1mm. Thats going to be more of challenge given that there is no absolute ‘home’ and that if it binds at all or crashes on the way back, it thinks it is at home when it isn’t…but all that is for a different forum topic.

1 Like