X-axis movement problems

I’m having a lot of problems with the X-axis movement, without the belts installed it works perfectly but when the belts are installed (as described in the documentation) it doesn’t move anymore. The friction at that point is too high.

Does anyone have the same problem? and might know how to solve it?

Thanks in advance!

Can you tell us what you’ve already done in attempt to fix the problem?

  • I tried to losen the tension on the belts and also to put on more tension.
  • I tried to change the power coming from the stepper drivers (adjusting the screw)
  • Adjusting the wheels on the downside to make them as loose as possible
  • Restarting the whole system

Without the gear belts it is running really smooth but with the belts it has a lot of friction and I can’t figure out what causes is.

First, equalize your gantry. If that doesn’t help, check your track alignment. Your tracks must be absolutely straight and parallel, or the gantry will bind.

Thanks for the tips!

We tracks now aren’t fixed/mounted properly, a construction for that will be done next week so I will try to get it up and running then :slight_smile: I will keep you posted!

If you have the tracks assembled without the underlying support infrastructure, you can try the following to equalize the gantry (it’s how I do it):

  • Power off FarmBot
  • Move the cross-slide to the center of the Y-Axis
  • Move the gantry to the center of the X-Axis
  • Go stand in the middle of your frame, next to the gantry
  • Grab the gantry, one hand on each far end (as close to the motors as possible)
  • Gently lift up your FarmBot by the gantry, so that the tracks’ “feet” are not touching the floor, and hold it there for a second

If there was any torque between the two tracks, it should now be gone. The gantry’s support columns will hang straight down, spacing your tracks precisely as much as it needs.

  • Slowly lower your FarmBot back onto its feet

Your tracks should not be able to bind your gantry now.

Oeh that is a great idea! I will test that as soon as possible!

I had movement problems before, one of x axis motors wasn’t working. The Farmbot is now mounted properly on a frame and can move smooth on it (when the belts are not attached)

I change the wires and the other motor works, I also switched the stepper driver which made no difference.

it was moving on the Y axe but also not on the Z axe.
I thought I burnt the ramps shield someone (one day there was a burned smell :wink:, I swapped all the stepper drivers to test, but without any result. I also tested with another arduino, also without result. I checked this way that all the stepper drivers, motors and arduino where okay.

I bought another ramps shield, exactly the same version of course :wink:
now I connected everything the y axe is moving, but reallyy slowly and it’s not giving the right distance it traveled in the widget. the z axe is making a beeping sound every time I press a button to move anything (also when I press a button to move the y or x axe) the x axe doesn’t do anything at all right now.

Does anyone know how to solve it? I have no idea anymore.

It is possible that multiple components are damaged, for example: both the Arduino and the RAMPS shield. Are you able to test with an Arduino that you know works and also the new RAMPS shield?