Z axis goes down when power off, is this OK?

Just as the title says, Don´t know if everything is too heavy or the friction between screw and nut is not enough

I just starting to connect everything, will the encoder correct this overweight doing a closed loop control? how it is the process to calibrate?

That is unusual. I just tested locally, and a substantial weight has to be added to the axis before it begins moving without power. You may have a slightly different tolerance between the leadscrew and the leadscrew block. We’re working on a firmware patch to keep the z-axis motor powered to keep the axis in place.

1 Like

Ok thank you for your reply. This is definitely not good to my robot. I also got another in the forum to have the same problem as me.

Please look at the video

So the theory says that tolerance between screw and nut is too loose. I have the following ideas but requires some adicional work.

Ordering another nut from you to test if problem is solved. Can I order it in relatively fast?

Manufacture another nut myself but the has 3 threads and it is acme. So in a CNC lathe I will also need special tooling to do it.

Another idea maybe not so direct is to cut the nut at the middle. Then adding some little spacers inside the cut. This will add pretension to the nut. Similar to the spacer used in the ball screws. That are used to remove backlash

A post was merged into an existing topic: Sequences acting weird

hello Kitfisto,

my sequencing is not acting weird, it just goes down when there is no power supply to the farmbot/servos

it is a mechanical hardware problem,
not software

I was looking at

I think it is not such a good idea to keep z motor enabled all time since farmbot is not moving most time of the day

I think this hardware problem should be resolved in another way. what would hardware experts can say about this? and how to solve it? maybe my nut came with loose tolerance. how are they manufactured?


Actually, I think what they have in mind is that when the z-axis is “idle” that they will use the encoder to see if it moves. If it does, they can reverse the movement.

If that is their intention, then this is the ‘normal’ way CNC machines operate – on all axis – not just Z. They hold their last commanded position using feedback from their encoders.

You are right

This will be an elegant way to solve it as long as enable can be on and off from the ramps.

I am not an expert but i think that in stepper motors If are enabled they are locked and consuming most of they power even if they don’t move. Just when you disable them current don’t flow through their coils and they became idle again.

I haven’t considered the power consumption yet, might be worth to measure. Does anybody know how much current they draw in enabled mode ? If there is a software solution in place, I totally agree that there is no need for enabled being default, however some people do not use rotary encoders. In such a case, one could simply home z-axis via a endstop each time before the bot start moving. This would not take much time and would also be a quite stable solution.

Using the latest release, you can enable or disable always on motors for each axis in the web app.

The latest FarmBot OS image can be downloaded here, with the new features available at my.farmbot.io.