Z axis Moving Slowly After Software Update

After the most recent software update, the z axis is moving at about 20% of its normal speed. I have not made any changes to the settings. The x and y axes are moving as expected. I am including a screenshot of my settings. Please advise if changes should be made.

@cregini17

It seems that your microsteps and steps per mm are not quite right- can you please set those back to the default value and see if that helps?

You can find the default values by hovering the :question: icon.

1 Like

Hey @RickCarlino

Made the changes you suggested and I had some unexpected results. I want to preface this by stating that those micro stepping settings were used last year to quiet down the z axis (which worked perfectly). If I recall we also had to modify the dip switches on the motor drivers. We never had any issues until the most recent software update. Upon changing them to the default settings, the fields disappeared all together. Additionally, the z axis is no longer moving. The position is updating on the web app as if the axis was in motion, but I am no longer able to get the z axis to move. Attached is the current settings after making the changes you suggested.

@cregini17

Whoops- OK let’s set that back to the value it had.

You can re-enable this by activating the “ADVANCED SETTINGS” feature- we recently put the advanced motor tuning settings behind an ADVANCED flag, since some users were changing the values and inadvertently breaking their motor settings:

image

Question: I am not sure when the last time you updated was. We recently added a “speed toward home” feature to prevent Z-axis stalls (the number of steps/mm required to go downward on the Z-axis is often significantly different than the steps/mm required to go up). Is it possible that you simply have a value that is too low for one of these settings, and you were previously using an old version that did not use such settings?

image

1 Like

Ok so I have set all of the Z-axis motor parameters back to their default settings. I’ve set all the DIP switches to low on the z-axis motor driver. Regardless of the position I set the z-axis to, I get a quick (very noisy) movement before it stops. Again, the web app shows that the position has moved to the desired location, but it is not happening on the machine itself.

Did you also reset the encoder scaling value? I noticed you had a non-default value for that when I looked at your account.

1 Like

Tried having the FarmBot measure the length of its z-axis to help calibrate the movement. After doing so, it is reporting the length to be over 7500 mm. When measured from hard stop to hard stop it is only about 650 or so. Any thoughts as to why this is?

Modified the encoder scaling value back to the default 5556. It has made the appropriate adjustment for the z-axis length. I’m now back to where I was early last year with a terribly noisy z axis as it descends. Do you have some known micro stepping values that have successfully quieted this down? Our FarmBot sits right in the middle of our cafeteria area (our is the middle school use case on your website) and having a noisy machine is not ideal.

@cregini17 Just to make sure I am understanding the root problem here- was the Z-axis slowness caused by the new “TOWARDS HOME” setting?

You might be able to set your dip switch, steps per mm, and encoder scaling changes back to the way they were and just update the “TOWARDS HOME” settings to a higher value if so.

Is that the case here?

Yes this must be the case because all worked fine prior to this update.

Unsure how to make this change as I have tried to bring the settings back to where I had them during the last functional run. The big question I have is with the steps per mm. Increasing microsteps per step from 1 to 4 should quadruple the steps per mm no? The auto adjustment quarters this number instead.

By my math, steps per mm should be 6.25 using 1/4 step microstepping (200x.25/8). Perhaps my understanding of the step concept is flawed.

Encoder scaling 1389
Screen Shot 2021-09-20 at 3.33.29 PM

@cregini17 We just made some remote changes to your device settings- are they working better than before under the new settings?

I’ll have to give the FarmBot a run when I get back to the building tomorrow. Would you be able to summarize the remote changes you’ve made so I can try to get a gauge as to why they work for teaching purposes? Thanks for your help.

I noticed that the steps/mm and encoder scaling were set back to their default values under single steps (25steps/mm and 5556). This is inconsistent with the documentation for 1/4 steps which should yield 6.25 steps/mm and 1389. These values auto populate when changing the microsteps per step field from 1 to 4.

The values that were set yesterday not only made the z-axis move even slower, but also incorrectly set the length of the z-axis to ~150mm when it should be closer to 475mm. For now I have set the values back to 6.25 and 1389, but I am still very confused as to why the max speeds are auto adjusting and what they should be set to.