Z-axis (TMC2208 driver) stalls after power up since OS10.0

So it figures out now, that after each power down/up my z-axis motor stalls all the time. The z-axis is the only one where i changed to a TMC2208 driver.
If I manually do a Farmware Restart via the WebApp it works again, until next power off/on cycle.
Any ideas here? If I cannot get this solved i would need to go back to OS9.2.2 which worked very well

@mbuchberger1967 v10.0.0 might be interpreting your old values differently than before, and you may be able to fix the problem by changing the speed / missed steps values under the new firmware. I have not been directly involved in the newest set of firmware updates, so I will need to check in with the team. I will report back to you tomorrow. This is the first report I’ve seen since the v10 release.

A few notes if you decide to revert to 9.2.2:

  • v9.2.2 can be found here. Express users should download farmbot-rpi-9.2.2.img. Genesis users should download farmbot-rpi3-9.2.2.img (notice the “3” in the genesis version).
  • If the problem persists, you may need to click the “FLASH FIRMWARE” button in the UI to downgrade the firmware manually.

@mbuchberger1967 Are these drivers from a third party?

@RickCarlino
Thanks for your answer. I have a FB Genesis 1.4. So the TMC2208 stepper driver is a 3rd party one, yes. I exchanged it a year ago, during OS 8.x, because of the very noisy and instable z-axis movements. It helped a lot and worked great until the change to 10.0.
It is 100% re-producable. Powering off FB and powering on causes the z-axis motor to stall for a very long time (like several hours) until it stops motor activity.
After pressing the Refresh farmware button in the web app, everything works smooth.
The web app shows me firmware version 6.4.2.G, the version did not change from OS 9.2.2 to 10.0, is this correct?

@mbuchberger1967 The only firmware versions that changed from v9.2.2 to v10.0.0 were the 1.5 models, but there were some updates to the firmware handlers on the Rasperry Pi side which could be a contributing factor. I can take a deeper look on Monday when everyone is back in the office. Thank you for the additional information, it will help us in isolating the problem.

In the interim, were you able to downgrade to v9.2.2 to regain control of the device?

Hi
I did not yet downgrade, but did reset my firmware every morning, in case you want me to try something…

BR

That sounds like it could be an initialization problem, though because I haven’t worked with drop-in TMC drivers in a few years I’m unsure. This is also a use-case we don’t test against in development because we don’t sell drop-in TMC drivers as upgrades so for now I think you are best off downgrading FBOS.

Hi,
yesterday I re-burned the ssd card with the FBOS 10.0. And now it seems to work again. So there might be some difference between OTA updates and a fresh burned ssd card. I will monitor it for some more days and give feedback here, just in case others would have the same problem.

3 Likes

Í can confirm that after the re-burn of the ssd my tmc stepper drivers are working correctly again.

1 Like

Unfortunately, since some hours the problem is back.
I still have 10.0.0 installed (there was an OTA Update but it didnt finish), and after re-powering or rebooting the FB my z-axis movement (wuth TMC drivers) doesnt work anymore, until I reboot the farmware.
This is really a strange behavior. Is there any chance to investigate this problem?

After re-burning again the SSD (now 10.1.2) it works fine again.

1 Like