Z-axis weirdness

I’m having some weird problems with my z-axis that has some up randomly after a long rainy weekend. For some reason, it seems to stall or if it doesn’t stall, it will go up and down several times very slowly while finding home. I sprayed the axis with some liquid graphite and that has seemed to help, but this almost seems like a software issue. It just started a few days ago. I’m also getting RPC timeouts in regards to this which is quite odd.

Any ideas?

@stre1026 Before getting started:

  • Ensure you’re running the latest version of FBOS. You can cross-check your version with the latest version by looking at http://os.farm.bot (v14.0.2 contains a Farmduino firmware update)
  • Ensure your MAX MISSED STEPS has a reasonable value (an integer lower than 15). We’ve seen an uptick in reports from users hitting issues when MAXED MISSED STEPS is too high.
  • (v1.5 only) Set your MOTOR CURRENT to an appropriate value. If you’re using the factory default of 600, try a higher value like 900.
  • (This is time-consuming, but might be worth it) Consider resetting your firmware to factory defaults and re-calibrating. Half of support requests for motor tuning problems result from users accidentally enabling values, or setting motor tuning values to numbers that are too far out of range. Resetting to factory defaults and starting over might help if you think this is the case or if there is a bad value floating around somewhere. It’s always a good idea to change one setting at a time and always revert values back to defaults if you are experimenting.

This sounds like your steps per mm is too low, or you motor timeout value is too low.

You can change the homing speed (Steps/MM) in the device settings panel. Be careful not to set the value too high and be ready to revert changes if you see unexpected behavior.

Please let me know if any of those help. I can remote in to your device if not, but I will need to know your device ID.

Hey @RickCarlino

Everything is on it’s default settings and latest firmware and was working great up until this weekend. The only thing I have changed is the motor current for the X-axis. If you remote into my device right now, you’ll see it’s actually doing it right now. The device ID is: 11807

1 Like

@stre1026 You had an unusually low Z-Axis timeout (10s). I set it to 120s and I think (but can’t confirm) that Z is homing again. Can you double-check?

Also, you have a very cool setup! :sunglasses: You obviously did your homework when it comes to camera calibration.

Hi @RickCarlino

That’s weird. I don’t recall changing that setting. It does seem to be better right now. I’ll let it go and see what it’s doing.

Thanks for the compliment on the setup. I really have no clue what I’m doing with the FarmBot and rely heavily on you and the forums/documentation for help :slight_smile:

1 Like