Z Home not stopping at Home - Express V1.0

Hi everyone,

Z is not stopping at home and continues indefinitely. Home works well on X and Y.

Here is the video. https://1drv.ms/v/s!Am764TSbUQr7hKwHtJF-wy3E5FY6GA?e=ZUQZcd

Thanks for your help. I have the feeling I used all possible config combinations.

Looks like your device is homing into the wrong direction. The axis is supposed to move upwards ( negative coordinates) for homing. Just invert the axis in the hardware settings.

Also it looks like your motor load is too high at normal movement. It is quite normal that the Z-axis needs a bit more power to move the axis up as there is gravity, a leadscrew driven drive and probably more load than on the other axes motors.
You can try to increase the motor current parameter for this axis in the hardware settings. The value in there is probably on default which is 600. Try to stay below 1000 when and play around until your motor is not too loud and the motor load is less. I do not own a express so I can’t give recommendations or share exact values.


Good morning @Ascend,

I can’t get it to work. It is homed at 0,0,0. When I click HOME it goes to + coordinates than to - where it does not stop
Configuration below.

There seems to be something wrong: why does the OS even let it go negative if the option is set at NO?

Thanks for your help.

Hey @JollyJoker

That sounds like a motor load detecting issue. I’m not entirely sure if my knowledge on how express devices are homing is still up to date as there were some changes recently, also I can’t tell the difference of STALL SENSIVITY and MAX MOTOR LOAD for sure. @RickCarlino could maybe know something about those, or is it rather something for Rory/Gabriel?
What probably happens, is that your motor moves into negative direction until a high motor load (probably MAX MOTOR LOAD parameter) is detected. Then it moves a small distance into the other direction followed by another move into negative direction until the motor load is reached again.
Having a MAX MOTOR LOAD set over 100% sounds like a mistake to me, as the motor could never go over 100% (right?) which always prevents the software from detecting the stall situation which is only detected by motor load. Check the motor load on a normal movement, I’d say it should be below 85%. Then set the parameter MAX MOTOR LOAD like 10% higher and see how it behaves. I hope that helps, thats how I would start.

You are most likely referring to the parameter NEGATIVE COORDINATES ONLY. This parameter does not affect the homing cycle for a good reason. Imagine your bot restarted while the X-axis for example is not at home. When searching for the home position it has to go into negative direction/coordinates to find it. This paramater only prevents you from moving manually into negative values and is usually needed for mirrored axes (Z-axis for example).

Just to make sure, your parameter to enable limit switches is not enabled right?

1 Like

Thank you very much. It all sounds logical now. Will try it out right away.

1 Like

So. I set home manually at 0,0,0, then moved to a plant. I set the load limit at 95%.
All motors went to 99% of load, therefore they stall, but the error informed is RELATIVE MOVEMENT FAILED.

The belts do not have a slag, but are not too tight either. I did not touch the wheels and when the motors are off I can easily move the bot in any direction. I even tried to loosen the belts a lot, still same issue.

I increased the load to the max of 1000 mA, still same issue.

That sounds really weird to me, but I’ve seen something similar in Rorys post:

Maybe a greater speed will help you to decrease the motor load?


@JollyJoker I’m having trouble finding your account information.

If you purchased your kit from FarmBot, Inc. please send your order number and web app account email address to contact@farmbot.io and we can help you with your movement issues.

1 Like

An incredible sense of satisfaction pervaded me when the FB finally concluded a XYZ move and then homed correctly.

Thanks a lot

Speed at 180, which is freaking fast compared to before, grace period at 1000, acceleration at 40,40, 12mm, than had to play with the load a little so that I can make my first sequence work, now at 1000mA.