Z Movement - Coordinate Error


#1

My students use a small “Mount Watering Tool” sequence as an opening Execute command. It has worked flawlessly for a couple of weeks (images pasted below) With no logical reason, the sequence no longer completes as written.

Issue: From the Home position, the UTM moves to the correct Y coordinate, but does not move the complete distance for the Z coordinate. However, the coordinate in the Move box reads as if it were in the correct coordinate position. In other words, the system thinks the UTM is in the correct Z coordinate.

In the Move box I can manually command the Z to move to any distance entered. So there is no issue with traveling in the Z direction.

My students are scheduled to demonstrate to the Superintendent tomorrow. So any feedback today would be most appreciated.

EncoderSettings1


#2

In addition to the previous images, here is the Log showing the attempt to pick up the Watering Tool. Even thought the Log indicates it moves to -220, this does not take place. In actuality, it moves about 20mm.


#3

Hello Jwells,

So if I understand correctly the Farmbot will move manually in the z-Axis but it won’t follow the sequence correctly?

I would suggest deleting the sequence, then start a new sequence and re-inputting all the steps.

Also, I would also check to make sure there’s nothing obstructing the movement of the Z-Axis motor or screw components. Sometimes dirt or debris can get into the components and that can cause problems.

Marc


#4

Hello @JWells

I just noticed two things that might cause issues to you:

  1. Your encoders are disabled. If an axis does not move or stall, the software can not detect it. But thats probably not your issue right now. For correct and secure movements, I would recommend to enable the encoders and the option USE ENCODERS FOR POSITIONING. Feel free to report if anything does not work as expected.

  2. Your setting STEPS PER MM seems to be wrong for the Z-axis. You can find the calculation (pretty easy) in the software docs. Just set the STEPS PER MM value for the Z-Axis to 25 and you will be fine.