Zero movement on all axis but worked briefly once?

We’ve assembled our Farmbot kit here in the UK over the last couple of weeks, but now having issues breathing life into it.

Once built and power turned on and configured we couldn’t get any motor to do anything at all. But after reading posts in the Forum we disabled the encoders and endstops and put the jumpers onto the correct pins on the RAMPS (there’s no info on the jumpers that we could find anywhere even though they are included in the kit). We had movement for a few minutes using the direction arrows but:

  1. The X axis motors moved but X1 axis didn’t seem to have enough power to move with the X2 motor and the belt slipped a little. We tightened the belt and freed up the eccentric bearings but still no joy with X1 movement…

  2. The Y axis moved OK in both directions – Result!

  3. The Z Axis moved down OK using the down arrow, but the up arrow also moved it down too?

To fix 1. we tried rotating the Stepper Diver Controllers a small amount clockwise then anti-clockwise hoping it might increase/decrease power as suggested by some posts in the Forum ( there’s no reference how to use these that we could find. Others on the Forum say just fiddle with them, which we did).

After the tweaking the Driver controllers we had no movement at all once more. It seems to seize on ‘Arduino is busy’ sometimes.

We rebooted numerous times with no joy. Even tried re-enabling endstops then disabling. But now it won’t let us disable the end stops.

Now getting a message about Tokens received by Farmbot we haven’t seen before and can’t find much mention of. But it’s a green message which we assume is good. But still nothing moves.

It’s very annoying as we had movement for a few minutes on all axis, but now it’s lifeless once again. We think it must be a software issues as we were very careful wiring up and it has worked briefly once.

Any ideas anyone?

I’m curious: why did you add them to the RAMPS if nothing in the documentation says you need to?

Check this thread for troubleshooting, but in my experience, your stepper driver is fried when it does that. (Swap them between a working motor and lazy motor, and see if the problem moves to the other motor, if so, you’ve got a fried driver).

Does it make a sound like in this video @ 0:33?

This greatly depends on the motors and drivers that you have. If you have those from the Genesis v1.2 pre-order kit, then @Loveny gave some detailed explanation about setting the potmeters on the drivers.

Thanks we’ll have a look at those potential solutions.

We put the jumpers on in desperation to get anything moving at the start. There’s a thread on here where someone got it moving when they added the jumpers, and it worked for us too, albeit briefly…

We’ll try swapping the Stepper Driver and see if that’s the issue. If it is we have a spare set of stepper drivers that could substitute.

Our Z axis made no unusual sounds, just the same sound moving down on the down arrow as it made moving down on the up.


1 Like

Jumpers are no more needed to be plugged anymore. They were used when the option Enable endstops was not ready, and endstops were enabled by default. This got fixed and you don’t need to plug them. If there are no endstops mounted (they are not shipped with the kit!) you should disable the endstops.

I’m curious why the jumpers are even shipped.

Pin jumpers are not required for normal use, but they are necessary if you want to use microstepping.

1 Like

Problems seem to be solved, for now. I think we tweaked the stepper controllers too far anti-clockwise after getting worried we may have rotated too far clockwise! Although they work logically, clockwise for more, anti-clockwise for less, it would have helped if this was mentioned somewhere prominently.

Also a pulley that had vibrated too close to the X2 motor had jammed it for a while and belts too slack (and internally twisted) on the X1 had caused problems.

now it works with each axis in the correct directions, with encoders enabled. Just have to figure out how to calibrate it now :slight_smile:


1 Like