Actual Position all over the place after Firmware update

A few days ago I switched the FamBot back on and let it sit for a few days. I thought that it will update itself and I will be ready to go. He mostly did but unfortunately set itself to the 1.6 instead 1.5 Farmduiono. This obviously lead to a failure in the Firmare update. So I changed it to 1.5 and started the Firmware update via the Webapp. But that lead to the actual position being all over the place.


I tried “Find Home” but it keeps stuck at the Z-Axis and wants to move and move and move.

Is there any way how I can reset the actual position to be 0,0,0 again?

After reading some parts of the documentation I tried the following on the X axis:

  • set home => no change
  • deactivated the Encoders => leads to the position changing to 0 and switching them back on changes the position back to 29828548mm (29,8km!)
  • deactivated Encoders then set home and switched Encoders back on => positon still at 29828548mm

I’d be really happy if somebody can help me here. Otherwise I won’t be able to plant anything :roll_eyes:

Have you tried power cycling (unplugging FarmBot from power and plugging it back in)? That should reset the encoder position tracking chip which provides the position values when encoders are enabled.

So I finally found the issue. Some parts are just my own stupidity… :man_facepalming:t3:

I was sure that I have a 1.5 Genesis because that’s what I initially bought. Also the issue with the Firmware update showing issues after this years power up drove me even more in that direction. So I changed it to 1.5 and the firmware flash was succesfull. But that resulted in the above mentioned encoder issue.
FACT IS: I have a 1.6 Hardware which I bought exactly a year ago due to power issues with the RasPi. I reflashed the SD card and set it all up new. Then chose 1.6 Genesis and reflashed the firmware. Now everything is as it should be. :partying_face:

So if anybody encounters the same issue: Make sure that you have selected the correct Firmware version!

PS: Power cycle did obviously not help. :crazy_face: But thanks for the help! :smiley:

1 Like