After 5.0.1 Update Z axis jerky going up

After flashing the 5.0.1 update my Z-axis has become jerky going up anywhere but X0Y0. At X0Y0 the Z axis moves up and down smoothly. Move away from the X0Y0, (either one, tested independently) and the motor seems to stop and start every 20-25mm or so going up. Going down is smooth. Go back to X0Y0 and Z-axis movement is smooth again.

As it starts and stops going up, it will stop if the number of retries is exceeded. On shorter moves it just looses a mm or 2 of alignment from true 0 each time it stops and starts.

Never had a problem under 4.0.1.

I would have thought wiring but it’s independent of x movement or y movement (ie. if I move just X and test, or if I move just Y and test) and it fixes itself if I go back to X0Y0.


Have you tried decreasing the maximum speed? You may have to modify the encoder settings as well; it sounds like the encoder is detecting too many missed steps. You can view encoder readings on the Controls page to make sure they are in sync.


I too noticed similar behavior last night and it frustrated me. The only troubleshooting I had time for was a soft-reset and that did not fix the isue. When I came home to trouble shoot it today, I started with a complete power cycle of the Pi. Strangely, the problem went away. I’m not sure this helps much, but it does give you another data point.

I also noticed that the encoder readings were off from the calibration that I performed last night (today, if I moved in the x direction 100mm, tell it to move back, and it only moved 93mm). After another calibration, it seemed to behave normally.


Same here with the z-axis; When moving upwards with the new OS the movement is jerky and farmbot retries several times.
This has not happened before. :frowning:

Decreasing speed has an adverse effect.
Turning the Z-axis alone, poses no problems.
Only in combination with x and y (at this moment). and with the Rotterdam Farmbot it’s the x-axis movement that shows the jerkiness. From 1 to 4 (temporarily) stops when playing with different speed settings.

We have readjusted the leadscrew… and that seems to help… less jerkiness (and noise), only a bit when the Z-axis speed changes.

Cutting the speed to 400 on the Z-axis has worked for me. It now moves smoothly up and down.