Arduino not connecting to Raspberry pie

I installed Farm OS 14.2 on a Pi 3 and connected it to a mega 2560. I tried it with and without installing the ramps v4 board. I cant get it to connect to the arduino. I was trying v1.2 ramps


Is it safe to assume you bought your Arduino board from a different vendor than FarmBot, Inc.?

Some third-party Arduino brands use a different USB port than the official ones. Usually that port is ttyUSB0, which is not auto-detected by FBOS.

Here is how you can manually set the USB port of the Arduino board:

  • Plug in the Arduino to the FarmBot.
  • Reboot the device.
  • Determine the path of your Arduino by looking for a log that says something like this: Detecting available UARTs: [“ttyACM0”, “ttyAMA0”]
  • Enable “SHOW ADVANCED SETTINGS” in the device settings panel.
  • Manually enter the correct path in the panel below (probably ttyUSB0).


1 Like

It worked! Thank you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.