Australia new farmbot build connection issues


#1

I can’t paste images atm, but we seem to be having the same connection issues others are. We’ve tried to connect through my phone and it says there farmbot is connected to the webapp but it wont connect the message brocker and the farmbot.

Any ideas what we can do?
On the webapp it tells us the farmbot connected last at (then it tells us the time).

The farmbot wifi does appear to still be available once it had been set up.

Does the farmbot need an internet connection 100% of the time?

We also have a school 2 step authentication process. Is it possible to connect using that that you know of?

Roy mcpherson
Atherton shs.
Far north queensland.


#2

It’s hard to say without seeing the actual error by the Farmbot WiFi, but school and enterprise networks have been known to have issues.

by default - yes. There is a setting you can toggle in the app to change this behavior.

Right now Farmbot only supports open WiFi networks and WPA-PSK based networks. I suspect your network is using WPA-EAP. (enterprise/school networks). I’ve been working on support for these networks, but it’s been slow because we don’t have a way to test it out.


#3


#4

Interesting it seems to be timing out while trying to download the latest OTA. You might try disabling “Automatic OTA” and then after Farmbot is up and running, manually updating. You can probably bypass this entirely by flashing the latest image as of 2018-08-08 22:19 PST

Please note that we are planning on another update tomorrow to address the bug listed in this threrad


#5

I’ll try the new image tomorrow. But how do you disable the ota and manually update it… in case.


#6

Btw. What is the OTA?


#7

Sorry, OTA: Over The Air update


Disable this setting. It’s about half way down the Device tab on the web app.


Then after Farmbot is up and running right above the auto update toggle setting, hit UPDATE


#8

Also are you guys working on wpa enterprise… i think we use wpa2? 2 step authentication in the future?


#9

It’s being worked on. I’ve got it working before, but i just don’t know enough about wpa enterprise configurations and haven’t researched enough to build the user interface, and backend code to make it ready at a production quality level


#10

I can report the new build fixed it. I re flashed the card and it worked straight away. Thank you so much.

We now have to put on the tool rest and rejig some of the cables as the motors are not quite “Free Flowing yet”. I was nt willing to move it too much but I had full motor control.

I did notice on the browser it lost connect and wet gray periodically though.

Will keep in touch and give an update on hows its going.


#11

I use a wifi extender to bridge between the WPA EAP and WPA PSK https://www.netgear.com/home/products/networking/wifi-range-extenders/default.aspx


#12

Just to give an update. Id love to try the wifi extender, i need to get our tech to check it out.

The farmbot is working in that it is connecting but we are having physical movement issues with the motors. The machine moves along the X axis generally ok but sometimes it binds easily and it throws an error. The Y axis movement however is wanting to not move properly and the belt wants to skip on the belt even though we have realyl tried to tighten it pretty well. But the other movement issue we are having is the Z axis. It moves well if I assist it with my hand, however as soon as it has to go under its own steam the motor struggles, almost like its not strong enough.

I wonder if the cables and tubes in the chain on the Z zxis is too tight and putting too much tension on the Z axis rod/ motor.

Has anybody had any issues with motor and movement. Should it be moving really easily?


#13

Turns out a wifi Extender will still breach the security of the network and is unlikely to be allowed, The farmbot needs to support 2 step authentication. There was progress on this. Where is the development of this upto?


#14

We are having massive issues with the Z motor and free movement in an ‘up direction’. Does anybody have any advice. It wants to bind and needs to be helped manually. I can get it to go pick up a tool, however anytime it needs to move up its like its not strong enough to do it? please help!