Axis movement greyed out

For the last couple of days the axis movement section of the web app has been intermittently greyed out. A refresh of the browser window usually fixed it.
Spring is here now, so I was going to get planting and growing. Today however, the “Go” button in the Controls section of the web app is always grey, regardless of the position that I select for a single, or multiple axis.
The Farmbot web app is showing a “Green” connectivity check mark.

These are the things that I have tried so far:

1/ Refreshed the browser window (using Google Chrome
Version 106.0.5249.62 (Official Build) (64-bit))
2/ Restarted the Farmbot
3/ Tried to use my mobile phone’s browser to move Farmbot.

There are no errors that I can see in the logs:

This might be important for other users. I have found the cause of the issue, in fact the answer occurred to me while driving the car, but I was not near the Farmbot and so couldn’t test my supposition.
The cause of the problem was that one of the axis wasn’t reaching home, so the movement options were grey, while waiting for the axis to all reach home. There was nothing that I could find in the logs that reflected this, but that might be just me not reading the logs properly.
I temporarily fixed the issue today by changing the Farmbot settings to not “find home at boot”. This stopped the Farmbot from taking forever to initialise and fixed my movement issue. I now need to fix the issue that was stopping the axis from reaching home, but at least I can now test things to see if my fix works.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.