Calibration of axis

Hello everyone,
My work on the farmbot has progressed, I had an initial issue with the encoders on my motors, which I have now solved, thanks to Chris and Ascend, and a late camera issue, which was solved by buying a new camera.
I have now completed constructruction of the rails, bed etc and have tested that I can turn things on and off, like the watering solenoid, vacuum pump, etc, using the web app.
I can manually move the axis for the full extent of their travel using the manual controls on the “Controls” tab of the web app, and have experimented with manually setting the axis to zero in the spot that I would like to be the home position. I have set the web app to only use positive values.
This works, and I can repeatably move to the co-ordinates that define the location of my various tools.
I can use the “Home” function in the “Device” section of the app, and it will find a zero position for the specified axis. When I select, for example, “calibrate X” from the “Device” Hardware" section of the web app, the Farmbot moves the X axis to the far extent of its travel at high speed, finds the point at which it can move no further, due to reaching the end of the axis, then starts to slowly move back towards the zero position. After travelling about 1/2 way, the axis stops moving and a red error message flashes up to say that “Calibration Failed”.
Is there any way to find out more detail / any detail as to why this error is happening? Is there a log somewhere with an error message? It would be of great help to know why the error is occuring, something like " maximum missed steps exceeded" or similar.
Spring is now here, it’s time to start planting :slight_smile: .

Try increasing the timeout value for the X axis so it doesn’t timeout and stop. I think the shop value is 120 I changed mine to 180. Also recheck your x axis rails are perfectly parallel, your Y axis is at perfect 90 degree angles to the x and your belts aren’t too tight.

Thanks Whitecaps, I’ll try that today. I’m pretty sure that the axis are parallel and at right angles, but I’ll check them anyway. The tightness of the belts seems to be a “suck it and see” system. so I’ll loosen them a bit as well. I wish I knew what it was trying to do when it stopped, some feedback from the machine would be very helpful!

I use the following on my x axis (need access to a 3D printer) and I am going to trial in the space between the rail and the Kreeklove. The spring will hopefully give me an indication depending on how bent it is on whether I need to tighten the Kreeklove or not. Well that’s the idea…

The tensioner and spring are a really good idea, fortunately I do have a 3d printer (and a mill and a lathe), I’m a bit of a tinkerer. I will print the tensioner forthwith.
I also checked the squareness of my machine, and it hasn’t moved, I loosened the timing belt on the X axis a bit, but the real solution was to alter the timeout for the X axis. X wasn’t obstructed, but the axis was moving too slowly to make it to the home position in 120 seconds and so timing out. I increased the value to 300 seconds, which allows sufficient time.
I do have a new error now, which is a write error updating the settings after calibration. I haven’t tried to solve it yet, but I’ll make a new post if I can’t.
Thanks for all your help and your excellent suggestions.

1 Like