Camera Calibration Rotation Issues

I am looking to use a borescope USB camera to image the bed once a day for records. I used the calibration sequence to rotate and scale accordingly, which worked beautifully.The only issue is that there’s currently black triangles in the corners of the image due to the rotation. These also show up in the farm designer when I enable photos. Is there something I’m missing?


The best for you is to manually rotate the camera in the support (that what I’ve done on our robot).
Put 0° in the field “Camera rotation” and try to adjust the camera the best you can, just by rotating it in his support.
I think images are stored on the server as jpeg, so you can’t have transparency instead of black background.


Alright I will change this. That’s a challenge, as the photos dont truely overlap then.
Well, I started making changes to the camera, and now the farm bot will not render pictures taken.
When I request a picture, the device sends the “Photo will be ready soon” pop up message, but the photo never updates. I have tried restarting and resetting the device.

[from a newbie helper]

  • Will the camera take any photo at all ? ( e.g… use take-photo Farmware )
  • Is some connecting cable not “connected” right ?

Cables are all connected just fine. The camera does not take any photos at all. The program continues as if it does take a photo, but no photo ever renders .

@DanJones Are you using a Genesis or Express model? We are receiving an increase in reports of camera problems from Farm Bot Express users. We are still investigating the issue but should have more information available shortly.

@RickCarlino, I have made a custom farmbot using a raspberry pi and Arduino RAMPS Board. In the web app, the device is set as a Genesis v1.2.

For more information, occasionally, farmbot gives me these warning messages when I try to take a photo

For more info, I get this success message after attempting to take a photo, but no photo appears.

Do you get the upper 3 messages only when taking a photo?
The last one “Problem getting Image” means that there was no image returned from the camera.
Make sure that the proper camera setting in the device section is chosen (USB/RPI). You could also plug the USB connector again, maybe into another port to check if there was a bad connection.

This message might be a bit misleading at that point, as this only means that the take-photo script has completed. It does not check if there came any errors while running.

@RickCarlino I think that could be improved. Is there a way to check the output from the farmware before sending the toast message? If not, we could simply change the text so that the user also checks for error logs instead of waiting for the image to appear after reading this positive toast message :slight_smile:

@Ascend, I only get those messages when taking a photo. My farmbot is connected to a public wifi at my local college. I had to clear the MAC address of the raspberry pi with the tech department in order for the device to successfully connect to the wifi.

@Ascend Thanks all the help! I have added your suggested verbiage update to my TODO list for a future release.

@DanJones, this one is critical.
Also, do you have a stable connection to the bot from the WebApp ?

Hello, I have some similar problem. I ordered the camera on the FarmBot site. When i calibrate the camera the settings in the calibration menu will automatically jump from right bottom to an other setting like top left. This causes the pictures turning on the map. I also have a problem with saving the settings in the my farmware tap. Is this some here also experience or maybe solved already? or is it me doing something wrong?