Can't launch parcel_1 docker


Since the last update on parcel that has been made 18 days ago, I can’t launch anymore the docker farmbot-web-app_parcel_1, I always get the same mistake

I tried on ubuntu server 18.04 and also 20.10.

Does anyone have an idea about this?

Thank you

@damien Can you try upgrading? There were some issues around that time with some upstream dependencies.

You may want to perform an upgrade:

git pull origin main
sudo docker-compose run web bundle install
sudo docker-compose run web npm install

Please let me know if that helps.

@damien One last thing I forgot to mention- you may want to do a fresh rebuild, also:

sudo docker-compose build
sudo rm -rf node_modules/ package-lock.json
sudo docker-compose run web npm install

In your screenshot it says:

No space left on device

Probably the issue. :slight_smile:


@jebba I’ve seen this be not the issue in the past and instead be related to inotify watcher counts, just in case anyone hits this issue and is 100% certain their hard disk is not full. That is to say, that message has been somewhat deceptive in the past. My understanding of inotify (or why that error happens) is limited.


Sorry for the late answer. I actually solved my problem by running this command : "
echo fs.inotify.max_user_watches=65536 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
" before the docker-compose up. Thank you for your help