Code 30 Farmduino firmware, no communication in between

Hello, want to discuss and share my experience I recently had. My system is quite new, only up for like two weeks. A side note probably linked to this issue? I’ve had some bad luck with the camera, rain water has entered the camera which caused it to break. → I already got the help via sending me a replacement. :smiley: Thanks!

So now to the issue: It all began with my Farmbot Genesis 1.7 not doing any movements anymore. Before It worked properly, for like two weeks. And also after the camera got broken.

As a first step, to troubleshoot the error, I tried to use the emergency stop, and unlock. → Did not help. Red button was blinking.
Next, I rebooted the Farmbot via webgui several times. → No luck, still Code 30…
Next, I shutdown the Farmbot, disconnected the power source and replugged. → No luck, still Code 30…

Pushing the flash button did not help, always got straight an error.

When looking through the logs I saw:
Detecting available UARTs: ["ttyAMAO"]

This was a bit strange, since I do have the Genesis model, I would expect to get ttyACMO

In the webapp I then checked If it would help changing the firmwarepath to ttyAMAO. And do a news flash. → No luck. Switched it back.

Next Idea was to hard reset the Farmbot by re-flashing the SD card. → Did not help, raspberry connection was good, but still failing in Code 30 error.

Next step was, shutting down the system and disconnect the power source and then checking the cables going from the Raspberry to the Farmduino. Unplugged the data link and replugged it. → Did not help.

Then after many hours of troubleshooting I decided to unplug the broken camera and switch the USB ports of the data link to another one. And finaly!!! The system was able to recover :slight_smile:

In the logs It was different, I think the UARTs got discovered correctly.

To understand the problem some questions to the community:

  • In case the camera would have caused a short circuit, could this have caused the issue?
  • What is the difference ttyAMAO and ttyACMO?
  • Could It be that some of my Raspberry USB Ports got broken, due to the camera issue? How can I test them?

I would really appreciate your toughts. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.