Communication lag and incorrect positioning

Hey everyone,

Today I’ve had some pretty strange issues with my FB. The communication between the web appand FB seems to be really behind. Ill issue it a move command and FB moves to the position, but if i look at the control tab the coordinates take a while to “catch up” i can see them increasing or decreasing until it reaches the number entered in for the position i want FB to be at.

Additionally, I try to execute a move command in a sequence and the FB does 1 of 3 things.

  1. move as if the position i’m commanding it to move too is reversed / the complete opposite of where I want it to go.
  2. it initializes sequence and then says sequence completed without any movement.
  3. Or the Fb crashes and then has to reinitialize the firmware and setting previous MCU commands

also to note:
when i was building a sequence earlier, everything was lagging extremely bad, i had to click 2 - 3 times to duplicate a sequence step, put it all together and then after a refresh of the web app, I look back at the sequence I had built and there is 2-3 additional sequence steps duplicated per command i was trying to duplicate.

Also been having this weird syncing behavior as me and whitecaps had discussed in this thread (not sure if related)

I’ve tried the good ole’ refresh of the web app, restarted FB 2 times so far and tried logging out and back in ( thinking it had something to do with the cloud storage).

I had similar lag issues today as well. Ended up rebooting a few times and restarting the web app as well. I didn’t see anything reversed, but several times it would run a partial sequence and quit. Rebooting seemed to fix that though.

1 Like

Same problem here, the complete web app is seconds if not minutes behind reality!

Please solve immediately!

yeah still having the same issues all day unfortunately! Rebooting does fix the issue but i’m worried ill have to reboot constantly at the event were going to show off the FB and our project! :grimacing:

I also cant create new sequences. Im constantly getting the sequence find error

the only time i can create a sequence is if i copy an already existing sequence and delete everything inside and then build in the copied sequence.

@Gabriel @connor @RickCarlino @roryaronson Any help from your side???

1 Like

Still nothing to report on my side.
I’ve just moved on for now by copying already existing sequences and then editing them for my need.

We identified an issue with FarmBot OS that is causing messages to lag. We are working on a fix that will be out this week. We’re also very close to deploying the new message broker system which will be faster and more reliable. Sorry for the interruption!


The lag issue has been resolved in FarmBot OS 5.0.4, which was published yesterday.

1 Like

Thanks for the swift response on this Rory and the team :ok_hand: you guys are awesome.

1 Like