Connection and Warning Message

I have two questions:

  1. About connecting to the machine. In the whole noontime, I cant connect to the machine with below message. I tried 2 hours but nothing changes… then 3 hour later, I can connect now without change anything. This is not the first time.

  1. I see warning message:Farmbot failed to install first party farmwares: %FunctionClauseError{arity: 2, function: :validate_repo!, module: Farmbot.Farmware.Installer.Repository} . What does it mean?

BTW, my camera doesnt work, not sure if it is related to 2nd question.


Hello @JerryZ

So you did the configuration via Farmbot Configurator, logged in into the webapp and waited for the Farmbot to connect. After some time (3h in your example) the Farmbot is connected to the webapp. Is that right so far?

Did you notice when it disconnected? Was your Farmbot running (any function) at any moment?

This means that your first party Farmwares (Take-Photo,Weed-detection, camera calibration, …) can not be installed. Without these plugins you obviously can’t use the camera.
I can’t see the exact reason what caused this error. I just tried reinstalling first party farmwares and its working.
Maybe @Gabriel can see any information in this message?

  1. For this time, YES, as you described. I usually find this problem… means the connection usually fail, then after hours or day, it can connect. This makes me trouble as I cant predict when can the machine successfully connect. BTW. the machine ever worked by moving X,Y,Z axis.

So your Farmbot keeps disconnecting and reconnecting multiple times over the day for long periods. Maybe your device is almost out of range of your WiFi network? The bot needs to disconnect and reconnect every 30minutes and for any reason some of those reconnects don’t work properly.

Wifi signal is consistency and strong. Bot is only 2 metres away from router.
Do you mean the bot is designed to connect and disconnect very 30 min.? As I dont see the log of this activity yet. My problem is I cant predict if the machine can connect successfully when want to operate it… and for sure… wifi works well all along.
BTW, I see it is auto upgrading OS over the air now. I see the progress is 13% over the night.

Yes, the software needs to refresh some things in this time. It will only need a few seconds and mostly you won’t notice because all you see is that it synced again.

I would definitely recommend upgrading your FarmbotOS first, at least to 5.0.9. You can either wait for it to complete,or flash your SDcard with the newest version manually.

1 Like

System upgrade to 5.0.8 3 days ago, I clicked update again to 5.0.9 but I dont see upgrade over air in the past 3 days.
Always with below screen… cant connect to machine either.

That’s strange. You would get a log message and the downloading progress in percent if the update got triggered. You could try to reboot the device and try to update again.
If this also does not fix it, you will need to reflash the SDcard using the image and installation guide on this page.

I would expect a DISCONNECTED button instead of SYNCING if its completely disconnected. If you refresh the connectivity diagnosis by pressing CHECK AGAIN, does anything change? Also try refreshing the page and logoff/login from the webpage.