Connectivity issue after the most recent update (Version 15.3.2.)

We are having some connectivity issues ( Connectivity code: 26) after the most recent update, Version 15.3.2. The FarmBot will sometime disconnect from the message broker. Once rebooted, it is back online. But it will run for a few hours then disconnect again. It’s very random and I don’t see a pattern here.

I am using a hidden network and the most recent update fixed a hidden network bug. I wonder if this is related.

Not possible. That bug fix only enables association with Wi-Fi AP “hidden” ( non-broadcasted ) SSIDs.

Just a thought . . this is the first extended test on that Wi-Fi router. Is there a firewall between it and the public Internet which might be silently closing connections to outbound port 8883 ?

Have you tried running the bot on a cellular phone network ‘hotspot’ ?

What are the on-off states of the blue and green LEDs when the issue pops up ?


Well this is interesting :thinking: : Checked my bot just now and see the same situation !
( blue LED is solid )

Looks like the MQTT broker ( at ) needs checking ?

We are using a TMobile 5G gateway, and there is no firewall. We ran our FarmBot on this network previously before the update with no problem. The issue first emerged in the week of that update.

I need to check with the LED again. I don’t think the blue light was on.

Assume you also used non-hidden SSID during that period ?

Maybe simple co-incidence of switching to hidden SSID and ( what I suspect ) a problem with FarmBot’s cloud-based ( ? Digital Ocean ) servers that provide the MQTT (over AMQP) connectivity for FarmBot Customers using FarmBot-curated Web App / API.

I’ll do some more investigations but might also be a good time to ask FarmBot Inc. to check that part of their infrastructure.


What is the status of the blue communications LED on your FarmBot electronics box?

In addition to the LEDs located on the Raspberry Pi, Genesis v1.6 kits feature LEDs mounted on top of the electronics box.

Box LEDs on Genesis kit

CODE 26 = CODE 10

FarmBot and the browser are both connected to the internet (or have been recently). Try rebooting FarmBot and refreshing the browser. If the issue persists, something may be preventing FarmBot from accessing the message broker (used to communicate with your web browser in real-time). If you are on a company or school network, a firewall may be blocking port 8883.

Troubleshooting Steps:

1.Try re-flashing your SD card and start the configurator process from scratch. You may need to start with a new SD card.
2. If your FarmBot disconnects and the error re-occurs try rebooting FarmBot and refreshing the browser.
3. A firewall may be blocking port 8883. Check these ports to see if they are blocked. If you are a company or a school please have your IT professional review this document.

  1. On FarmBot Genesis 1.6 units or FarmBot Express units check the blue LED communication light. You have blocked ports if the blue LED is OFF and the green LED is on . (Only FarmBot Genesis v1.4+ and FarmBot Express models have this diagnostic green and blue LEDs.)
1 Like

Yes. I was on a non-hidden SSID during that period.

This week, I will try to re-flash my farmbot and see if the issue persists. Thank you for your response!

1 Like

Thank you. I will try to re-flash my SD card and reconfigure my network to see if it solves the problem.

@jsimmonds @Marc Neither of my blue light nor green light is on but my FarmBot is still connected. And I think I only saw the blue light on once, and it has been off most of the time… Is there something wrong with my FarmBot?

I reflashed the sd.

I am testing on both of my phone’s hotspot and my T-Mobile 5G gateway, and no blue/green light.

And is your bot on-line and stable ??

Yes. It is online and stable so far. I turned my WIFI into a non-hidden network now to see if this was the issue.

Also, one thing I found out yesterday was that by default my 5G gateway would configure 5Ghz/2.4Ghz automatically when new devices connect to it. But when searching for wifi signals, my bot would regard this wifi as open wifi (no password required, so no way to input a password.) I had to specify my 5G gateway’s WIFI to be 2.4GHZ or 5Ghz with WPA2 so that my bot can scan this wifi as protected (so that I can input a password. ) So, maybe I changed my WIFI settings at some point and this caused the connectivity issue.

These are the settings I changed yesterday. I will let it run and see if i run into issues again.

Thank you for your help!

1 Like

I’m not so sure. I’m suspecting some transient issue with the AMQP cloud servers that the public FarmBot Web App uses ( remember I detected my bot also had a solid Error code 26 around that same period ).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.