Custom server, Error opening AMQP connection for OTA certs

I am currently setting up a server (self hosting). The server is using port 80 for the app, I have not yet configure SSL (that will be a future question).
I have the log “Error opening AMQP connection for OTA certs {:error, :econnrefused}” everytime I reconnect my farmbot. I think it’s triggered by the following line :

I think it’s an issue with my server configuration, I don’t have this message when I use your service Everything (except custom Farmwares) is running well. What mean this error and can I ignore it?

@Pitou You will need to configure RabbitMQ to handle the correct certificates. The server at uses a managed host, so it is not something I have ever had to do and not something I can spend too much of my time investigating. If you are willing to do the research on it and find a way to use custom SSL certificates on a self hosted machine, I would be willing to update our build system to support it. Please let me know if you find anything out.

@RickCarlino I am also getting this error on a self hosted environment. Does my environment call out to Farmbots to retrieve a cert or is the cert baked into the opensource by the build system as I think you are saying?

@whitecaps I think FBOS is trying to contact NervesHub (service that handles OTA updates), but most likely is missing credentials. I can take a look later this week if I have time (still figuring out my priorities for the week). Is this problem stopping you from self-hosting right now, or is the device able to recover from the error? I occassionally run my devices on a self hosted setup for QA purposes and have not seen any issues recently.

Thanks. I will take a look and let you know. Usually the device works fine for a while then the steppers stop working but the periferals still work. It also can cause issues with manual sync (not autosync).

Could I create an instance of Nerves Hub or change some config or is that connection hard coded into the FBOS?


Unrelated question- why are you not using auto sync? We had a discussion last week about removing manual sync. It’s been eating up developer time to write features for two different sync systems (QA, customer support requests, new features that need to take both settings into account, etc…) and one option we’ve discussed is getting rid of manual sync, since less than 10% of users have opted out of auto sync.

We realize that some users have reported “phantom data changes” on accounts that have poor connectivity, but those issues should be fixed in the next release of FBOS via the use of optimistic row locking.

You can, but I won’t be able to help you too much. That feature was built out by Connor, who does not work at FarmBot anymore and FarmBot uses the main instance of NerveHub rather than self-hosting it. There are some instructions in example.env. The NervesHub team is very friendly and has a Slack channel where they might be able to answer your more specific questions. Their lead maintainer, Justin, is a FarmBot owner.

I had problems with autosync in the past if those issues are fixed then all good I’ll stop using manual sync.

Cool regarding Nerves Hub I will look into it. Looks like an interesting project :).