Does anyone have the Farmbot kit working with the supplied encoders yet?

…If so, could you post a screenshot of your full device settings please?

Our Farmbot seems to be working on all axis but the encoders don’t register missed steps when they reach the end of a axis. We’ve tried reducing Max Missed Steps down from 10 in 1 increments even to zero, but the motors carry on running when they reach the end of the axis, even though they are not turning, just vibrating a little. We’ve tried turning the stepper power down to the minimum to move but still no joy. So we need to eliminate device settings before looking elsewhere.



Did you enable them in the settings? ( and check under Advanced) Check the plug connections?

Yes, encoders enabled and we’ve double checked the connections.

Have you tried with both FarmBot OS versions 3.1.5 and 3.1.6?

You can check that the Arduino is receiving signals from the encoders. See the rest of this topic for how to view the encoder readings.

Yes, we started with 3.1.5 then upgraded to 3.1.6 to see if that would make any difference and it didn’t. Will look into the encoder reading signals as you posted. Thanks.