Encoder giving strange values

I have progressed calibrating my x and y axes using the encoders and without encoders the Z axis is also working, but the encoder is showing strange behaviour.

When i try to move the FB using manual mode in the webapp the encoder values jump all over the place and are generally quite low (100 mm movement show raw value variance of 40-60). Manually without encoders the motor will perform the movement just fine, but the moment i turn the encoders on, I can hear and see the software struggling with retries and the movement is not completed.
What is even more strange that at the moment I disconnect power from the z axis motor and move the lead screw by hand, the encoder values is changing and showing more consistent behavior.
I have set the A4988 stepper driver to 4 microsteps

I have tried various settings, have checked the cable and have reflashed the FB but no success. Any ideas anyone?

What version of the Farmduino are you using?

I had a similar but not 100% the same problem with the encoders on a v1.5 board. It was a problem with the board so Farmbot gracefully replaced it. What I did to test it is below in the email I sent to Farmbot. Also make sure the board version is set correctly in device settings.

Original Email…
I think the Farmduino v1.5 board I received from this order may be faulty. My stepper encoders work fine with my v1.4 board but I can’t get any encoder readings from them from the v1.5 Farmduino.

I have done a hardware reset and tested both boards simply by leaving the factory device hardware config settings as is i.e. encoders not enabled. I have checked all the connections.

I get the following results:

v1.4 Farmduino I’m getting encoder data: move Y 10

v1.5 Farmduino I get no encoder data: move X 1

I have tried enabling and inverting the encoders and I get the same result.


Signal measurement of encoders (CH1=A+, CH2=B+), indicate inconsistent readings in B signal.

Expected signal:

My steppers and encoders are quite old probably v 1.1 or 1.2 could that be the reason? Still strange if they work on v1.4 but not v1.5.

Hi @whitecaps, thanks for your reply. I am on Farmduino v1.4. Before going forward with a warranty claim, I need to do some more investigation and it is strange that manually the encoders do work.
How did you get the signal plots?

It was using an oscilloscope on the voltage setting.