Ethernet Connection Issue


#1

I have recently powered on my FarmBot for the first time and am running the startup sequence for getting connected to the web app. Our school runs a WPA-EAP wifi so this is not currently an option. Oddly, I have been able to connect to our wifi network using Raspberry Pis before by modifying the WPA-supplicant file. Given that I am connecting via the Configurator, I am only able to enter the credentials for WPA-PSK. For this reason I must use an ethernet connection.

Upon entering my NTP Pool server, Domain, a pair of Name Servers, and our static IP address, subnet mask, and gateway, I am unable to have my device come online via the web app. Also, it does not appear that the Pi actually reboots upon completion, but instead shuts down. I must then unplug the FarmBot and then plug it back in again.

Please advise about the reboot and if any additional information is necessary to connect via ethernet.

Cheers.


#2

Static IPv4 adresses will only work in the next release (@connor fixed a code bug recently which I uncovered).


#3

That’s a bummer. When you say next release I assume you mean the OS? How often does this happen? Is there a target date?


#4

I’m just like you, dipping my toes into the world of FarmBot, and not part of the FarmBot organisation !
I’m sure some-one will give you an official response quickly :slightly_smiling_face:


#5

I think a way to bring a topic to the attention of the FB Team is to add them in the thread, like this:
Hi Rick! (@RickCarlino) can you add any light to this topic?
(Rick is the software dude, I think…)


#6

@RickCarlino @roryaronson I have been alerted to a bug by @jsimmonds and subsequent new release of the OS. Any idea when this will go live? I see there is a Beta version of of 6.4.12 but with an .fw filetype that I cannot open or flash. Any insight on how to take this for a test drive? They have tried Wireless DHCP, Static Ethernet, and Ethernet with DHCP enabled. These are the error messages they are receiving:

Wired Static IP Address Error:


Wired DHCP Error:

Wireless DHCP Error:

I’m getting quite a bit of pressure from district brass about getting their investment online.

Thx.


#7

@JayM026 Bringing you in on the thread


#8

Hello Farmbot Community!

Im part of the IT Staff attemping to get this device configured on our network. Can you please explain what the definitions are of each of the categories?

Like what is IS_RSA.PUB? DNS Test Name? NAMESERVERS? None of these settings are explained, Also none of the areas are marked as to What is required and what isnt. I understand we want to make this device static on our network so i assume it needs the IP Method Selected, IP Address, Subnet, Gateway. is NAMESERVERS DNS? Can Multiple DNS be entered here if NAMESERVERS is really DNS?

My question is how does it do its Checks for DNS is it pinging the DNS Server?? What are some possible reasons the Setup would Fail? We loaded the Older Farmbot Software 6.4.10 to avoid the possible static ip issue in 6.4.11


#9

Hello.

ID_RSA.PUB is an SSH public key to allow getting SSH access to Farmbot. this can be left blank.

DNS TEST NAME is the name that Farmbot should test to determine part of internet connectivity. This can be left blank if you are using Farmbot’s public server.

NTP POOL SERVER these are NTP servers that should be accessible on the network somewhere. They default to 0.pool.ntp.org and 1.pool.ntp.org if these addresses are accessible to your network, you can leave them blank. If not, you will need to supply your own ntp addresses or domains.

DOMAIN is a for static ip config.

NAMESERVERS is for static ip config. You can supply several nameservers split by a comma.

All that said, i think as @jsimmonds has pointed out there has been a bug for static ip settings for a while.
I have a fixed staged, and we are QA’ing it for a release.


#10

Gotcha, so the static IP isnt going to work until this new image is ready. Ok thanks for the response this answers alot but to clarify one part, what information do you need for the Domain section? I understand its needed for the static ip configuration, but what domain am i inputting into this?


#11

If your network doesn’t require it, you can leave it blank. I believe it is for things like Samba and other Windows tools that Farmbot doesn’t need or support.


#12

If you are interested, the current beta channel has the fix. The only problem is an .img file is not posted for beta releases. If you have a Linux or OSX machine available i can walk you through flashing the OTA file. This would be helpful to me if you have the time, since i can’t really test static ip settings.


#13

There’s this thread which could help you.
(Found it using forum search at the top of the front page)
I suspect that your (static wired) DNS resolution not working was an external firewall rule, since the IPv4 address would have “defaulted” to DHCP because of the bug referred to.


#14

I love testing Static IPv4 addressing on Ethernet :sunglasses: I’ll post my results.


#15

Hmmm . . static Ethernet still no-worky on beta branch . . I’ll see what I can uncover :confused:

/ pst: how do I look into the Configurator’s finished database ?


#16

Just a quick FYI, we tried just setting this up with DHCP just to ensure the farmbot was functional and it still failed to complete the setup, what else should i be looking for? The DNS resolution i will double check with out network team to see if we have a firewall rule in place.


#17

That would be cool however It looks like @jsimmonds already attempted to test this and its still not working :sob:


#18

What was the error? I suspect that your network does not allow access to ntp or there are some ports closed.


#19

if you have a console you can to something like

iex()> Farmbot.System.ConfigStorage.get_config_as_map()

There is also a sqlite database on the sdcard you can inspect on a different machine with a gui tool or the sqlite command line client


#20

The Error was the Last Shutdown Reason FarmBot is unable to make DNS Requests to Https://my.farm.bot. What ports do i have to ensure are open?