Farmbot Connectivity Issues


Our school purchased a genesis 1.3 farmbot in 2018 and have had it running on and off for a few years. However now when we try to connect to the farmbot it is unavailable and the web app cant connect. We have tried running it off various firewall free networks and replacing the raspberry pi and updating the firmware several times to no avail.

Just wondering what other troubleshooting steps or methods we could try?

Hi @THS_FARMBOT I would be happy to help you get your bot back online.

The part about the bot running in 2018 is a very important piece of information. I will assume that like many other schools, your device has not seen a lot of use during the pandemic, shutdowns, etc…

Here’s what I would like you to try:

  • Perform a hard reset of the device. Do not attempt to reset the device from the web application. You will need to do a full powerdown.
  • (assuming the device does not work after a hard reflash) Notify your school’s IT department that FarmBot’s port requirements have changed after the release of FarmBot OS v13. We have published a document for IT professionals that manage network settings.

My guess as to why your FarmBot does not work:

  • You did not have AUTO UPDATE enabled. When your device went into disuse, the software became so outdated that it no longer is able to communicate with the cloud server.
  • Your IT department only allows certain TCP ports to be used by the device. The port requirements have changed since the release of FBOS v13. The document above will provide your IT department everything they need to get it running again.

Please let us know if you need more help.

Hi, @RickCarlino I have performed a hard reset of the farmbot with it still not connecting to the web application. The network I am connecting to is a mobile hotspot from a router powered by a sim card. I removed the password of the network to determine if when farmbot connects to it is the issue. This network is completely free of firewalls and separate from the school’s wireless entirely.

Just wondering what I can do to fix it?

Hi @THS_FARMBOT . . does your Web App user account still work Ok ?

Do you have normal Internet access from that AP ?

Hi @jsimmonds i have normal internet access from the router and the web account is fully functional.


Thanks, just wanted to eliminate those possible causes.

Other potential issues include ( during Configurator setup phase )

  • Choosing wrong Wi-Fi SSID or a “typo” in the passphrase
  • Typo in Web App Username or Password

Are you in a position to check these ( again ) ?

Hi, @jsimmonds
I have checked the SSID and the web application works fines but after i configure the network
the raspberry pi does not display the farmbot network anymore and is also not able to connect into the web application. In addition I have tried various different security settings on the router and isolated the raspberry pi from the farmduino.

Hi @THS_FARMBOT a few more questions :slight_smile:

  • Which model Farmbot device do you have ?
  • Which version of FBOS did you re-flash ?
  • Did you try using a different and known good SDHC card for flashing onto ?
  • Is the mobile AP that you’re using offering the SSID on a 2.4GHz service channel ?

Hi @jsimmonds

We have a farmbot Genesis V.1.3 and we flashed the latest version FBOS onto it. We have tried multiple different sd cards with the same results. The mobile hotspot is running off 2.4ghz so it should be able to connect to the raspberry pi. Interference has been tested in several different locations and with the raspberry pi directly next to the router. I also tested it on another firewall free home network with the farmbot still not connecting.


Seems you’ve exhausted the “easy fixes” ( apart from a new RPi3 :slight_smile: )

Maybe time to bring out your handy serial console cable ( e.g. this one ) and then we can look at the FBOS log records.

I’m hoping @RickCarlino will offer some of his wealth of knowledge and experience to this thread.
( e.g. the MQTT and REST API endpoints are fully visible to FarmBot Team members )

Hi @jsimmonds

I have tried using a different raspberry pi 3 with the same results. I will look into getting a serial cable to view the logs.

Thank you for the help

1 Like

Hi @THS_FARMBOT a few things:

  • Please add the password back to your WiFi router. FarmBot might work with unprotected networks, but it is not something we actively test against.
  • When you say that you have normal internet access to the router, is that the same router that the Hotspot is using? If not, have you verified that a laptop (or any device other than the Farmbot) is able to access the internet via the hotspot? How is the signal strength to the hotspot on a non-FarmBot device when accessed from the same location as the FarmBot? I ask because there are currently no active connectivity problems with FarmBot OS so I have a hunch that your problem may be related to the hotspot or its configuration.
  • What is the model number of the hotspot you are using?
  • Can I see a screenshot of your connectivity panel a few minutes after you run the configurator? Here’s an example screenshot of the connectivity panel (though yours will most likely not be green):

This screenshot gives me information that I can use to remotely inspect the device under some circumstances.

Other things to keep in mind:

  • Entering bad Web App credentials will occasionally cause the device to silently fail and give the impression of bad WiFi credentials (since the bot is online but it is not able to send logs to your account).
  • Ensure that your WiFi hotspot does not have any sort of power-saving mode or auto-off feature. If the WiFi of the hotspot goes down during configuration, FarmBot may assume that the WiFi credentials were not valid and soft-reset itself (thereby going offline permanently). This is not an issue after the configuration completes successfully.

Hi @RickCarlino
The WIFI router has normal internet access to devices other than Farmbox when tested. The signal strength from the hotspot is high as during testing it was directly next to the raspberry pi.
The hotspot being used is a Huawei E5787Ph-67a Telstra Pocket WIFI system.
Below i have attached an image of the farmbot connectivity panel.
I have also tested connecting through wired ethernet connection with the raspberry pi but it still does not connect to the web app.

Also just wondering during the WIFI configuration of the farmbot whether in the advanced setup I have to change any settings as the network is Australian not the US.


Yes, you should change the Regulatory Domain in the Advanced Wi-Fi Configuration from US to AU

Are you able to login to that Huawei AP as admin and check that your Farmbot is associating ?

I am based out of the US, so I can’t speak from experience with regard to Australian network hardware, but it couldn’t hurt to set it to the correct jurisdiction. Conversely, since you mentioned that you had issues with Ethernet also, it might be an unrelated issue.

@jsimmonds brings up a good point about the administration panel of the router- checking to make sure the device is getting onto the WiFi at all is a good next step. Once we have that information, we can know if the problem is the network configuration or the account configuration. It may also be possible to perform a WiFi network scan (to check for devices on the network) using a tool such as Fing. If the device is at least online, it will show up on the network as farmbot-wxyz or similar.

If the device is in fact on the WiFi network, it is possible to see device logs by visiting, where is the IP address of the device (you can find the device IP using Fing or your router admin panel). The logs will stream in real-time.

Based on your screenshot, it looks like your device was recently online (2 months ago) with FBOS v11 (14 months old). You mentioned that you flashed the latest version (which is good), but I would double-check that the configurator screen says “14.4.1” when you open it, just in case the new version did not properly flash.

Depending on how much information was originally on your account, you could also consider performing an ACCOUNT RESET, as we have seen a very small percentage of users that had old/corrupt data on their web app account that prevented the bot from coming online. Depending on how much saved work you have, you may want to hold off on trying this until other troubleshooting means have been exhausted.

Please let us know if the router shows the bot on the network and we can go from there.

@THS_FARMBOT I brought your issues up today at our daily status meeting. Here’s an idea that came up:

  • It is possible that the issue is related to some corrupt or outdated data on the current account.
  • To test this theory (and avoid deleting otherwise useful data on your current account) you may want to try creating a new “throwaway account” on and reflashing / reconfigurating the device to that account rather than your current account. If configuration succeeds under these conditions, it is likely there is bad account data on your account somewhere. If it still fails, then the problem is most likely network related.
1 Like

HI @RickCarlino and @jsimmonds i checked the network and found that the raspberry pi was connected successfully. I then created a new farmbot web app account which worked and now the farmbot is up and running, so i think the previous account must have been corrupt.
Thankyou for all the help with getting the farmbot up and running.

1 Like

Glad to hear you are back up and running @THS_FARMBOT . Since the issue was most likely corrupt account data you can:

  • Delete the account and sign up again using the same credentials
  • Hit the “RESET ACCOUNT” button in the device settings panel to reset all your data.

Please let us know if there’s anything else we can do to help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.