Farmbot Express XL Firmware connect/disconnects

I seem to be having a known issue regarding getting my farmbot to stay connected long enough to give it commands, It will move slightly and give a relative movement error and then seem to disconnect from the raspberry pi to the farmduino. Sometimes getting a uart ttyAMA0 ttyUSB0 error on reboot

I was able to complete the setup to testing the X axis when these errors
began to occur, here are the stats from my.farm.bot in the images below and within realtime my device information :
Device ID: 28204

Version: v15.4.7

Model: Express v1.1

Firmware: v6.6.25 Farmduino (Express v1.1)

Please assist me, I am still trying to be hopeful.

I do not know if it is relevant, but I have seen strange things with Wifi with dead spots in the Wifi. In one case I had a perfect deadspot on my dinning room table. Move 1 ft to the left or right worked but there was a complete deadspot. I changed the channel, which solved that issue.

So.
If the FB is in a fixed location where you have a good connection, are you able to send it commands (that do not move the X,Y) successfully?

Have you always had this reliability issue?