Farmbot goes offline every hour

hello, my farmbot goes offline every hour.

this is the sequence that keeps comming back.

Interface wlan0 connected to local area network
Success: Firmware flashed. MD5: 668755B70C1
Interface wlan0 connected access point
Detecting available UARTs: [“ttyAMA0”, “ttyUSB0”]

the wifi point is 3 meters away and is has a stable connection.

can someone help me?

kind regards,
Stephan van Leeuwen

@Stephanvl These are diagnostic messages. They are not necessarily an indication of any problems. Aside from this message, is your device experiencing any problems that prevent it from working? We plan to remove them from user-facing logs in a future release to avoid confusion.

hey Rick thanks for the reply. my farmbot is getting offline now and then. I figured out I has someting to do with te event scheduler. when I have nothing in the event scheduler I have no problems. when I put in my daily sequences I get the “problem” I discribe here above. When I put in al the the things I want to schedule my farmbot crashes all te time.
my regimens dont work at all. that’s why I put all the daily sequences in lose in the event scheduler

I also had this problem last year but suddenly it disappeared.

connectivity is red and the farmbot-massagebroker link is instable.

can you please help me?

kind regards,
Stephan van Leeuwen

@Stephanvl That sounds like it might be related to a bug that was recently fixed but which has not been publicly released yet. It is actually related to the database rather than the network.

A few questions:

  • What is your device ID? Please leave your device online after providing it so that I can remotely inspect your device.
  • Would you be willing to try the latest beta version of FBOS? Version 14.1.0-RC6 may have a fix for the farm event problems you are describing. Please read this document for more information on how to install a pre-release version of FBOS.

Hey Rick thanks for the super quick reply!

My device id is 7102. Feel free to look around and remove scheduled items to see what happens. I re-schedule them later.

I forgot to say that if I schedule something for a long period of time like 5 months I also get the problem.

I am willing to install the beta version I will install it tomorrow!

OK, sounds good @Stephanvl . If you would like, I can perform the upgrade for you remotely so that we can start collecting errors immediately. Please let me know. I will hold off on inspecting the device until after the beta is installed.

@Stephanvl I’ve remotely upgraded your device. Is your device operating in a corporate network by chance? Specifically, is it operating in a network with security measures in place such as DNS filtering, firewalls, etc? Did the problems start around the time that you upgraded to v14?

If that’s the case, has your IT department seen this document?

Your device is behaving similarly to devices in school/enterprise settings so I am suspicious there is a local network issue at play.

Hey Rick,

Thanks!!! I was verry busy today so I couldn’t reply.
My farmbot is on a home network. I have a deco meshed network but I have farmbot linked to one specific WiFi point.

Do I need to forward a port or something?

I wil read the document and I hope i can fix the problem!

I keep you posted!

@Stephanvl If you don’t have any ports blocked, that should be fine. FarmBot does not need to host any servers to operate normally. Here are some ideas that will help isolate router issues:

Option I: cellular tethering. To rule out issues with the router, soft reset the FarmBot and tether it to a cellphone. Let it sit for a while to see if the problem comes back.

Option II: Use ethernet in “headless” mode. Soft reset the bot. Uncrew the Pi from the electronics box carefully. Bring the Pi inside and power it up via USB cable. Plug the pi into the router via ethernet and reconfigurate. Monitor the device for outages.

If the bot works in either of those setups, then we can be fairly certain it is something about the LAN configuration rather than FBOS. I did not see any particularly telling logs when I inspected your device today.

Has it always been like this, or did it happen recently?

Hey Rick,

The options you mentioned I already tryed.
I pulled al long Ethernet cable from my router to the garden. I tested different things along a view weeks. I also tried to connect to connect to a old phone with a hotspot. Both work similar as a the WiFi connection. Everything oké until I use the event scheduler. Yesterday I removed al scheduled items and this morning it was running normal. No crashes or the massage every hour. Just half an hour ago I start to schedule events just for today. After 5/6 events the farmbot crashed again.

I also tried to forward port 8883 but no effect.

I wil try the cable and hotspot again tomorrow!

@Stephanvl Please make sure you try it on v14.1.0, which was released a few minutes ago.

Hi @RickCarlino, just found this thread. I’m experiencing exactly the same problem, but in a local network. Scheduled events suddenly stop because of this issue. Given our bot is running using a local instance of the WebApp, any idea how we could update our software?

There’s not much I can do to remotely inspect devices on privately managed servers.

Make sure you are running the latest version of FBOS and the Web App before proceeding.

To update your Web App software:

sudo docker-compose down
git pull origin main
sudo docker-compose run web rails db:migrate
sudo docker-compose up

After that, perform a “hard reflash” to the latest version of FBOS on any devices that use your server.

Please make a new issue if you require further assistance.

@ladiazgarcia There are a few other steps you may need to perform, actually, depending on how long you’ve gone without an update.

An updated set of commadns to run:

sudo docker-compose down
git pull origin main
sudo docker-compose run web bundle install
sudo docker-compose run web npm install
sudo docker-compose run web rails db:migrate
sudo docker-compose up

Thanks for your quick response: Before opening a new issue… we are running 14.2.2. Im assuming the bug fixes related to this issue are not included on this release, right?

@ladiazgarcia I don’t know. The reason I ask you to update is that we do not support old versions of FBOS or the Web App. Certain bugs are fixable simply via an update and this issue is three months old. Please open a new issue and we can go from there.

1 Like