FarmBot, Meet Onshape

Hi all,

Perhaps you have seen our email newsletter by now with the big CAD announcement: we’ve switched from using Solidworks to Onshape. With Onshape, anyone can access and edit the native CAD models for free in their web browser or using one of the Onshape mobile apps!

Check out the native v1.1 CAD in your browser here: (Note: you will need to make a free Onshape account if you want to copy and edit the CAD)

And read all about the switch on our blog:

We think this is going to change the way we work together on hardware, and can’t wait to see you all begin modifying parts, contributing designs, and downloading/making your own components!


This is great! Thanks for switching over! I was planning to use Onshape for my FarmBot adaptation, since I can’t afford SolidWorks. Excited that we’ll have a community on there.

How Do I copy the Onshape files so that I can Edit the components?

In Onshape when I open the Farmbot CAD files l I can see at the top of the document it says “Make a Copy”

However when I make the copy the file is empty and it doesn’t have any part information in it. I want to edit the seeding tool Luer Lock Needle.

Tell me how I can make a copy so that I can edit the part?

When you press the “Make a copy” button, Onshape will copy the entire Workspace into a new document which will include all of the parts, drawings, assemblies, and other files.

When I just tried this, Onshape made the copy and then opened up a Part Studio named “Screw Hole Templates” by default, which is a fairly empty looking Part Studio. My guess is that this is what you are looking at as well.

To find and open another Part Studio in the Workspace, press the button in the lower left of the screen to open the Tab Manager. Then find the Part Studio you want by looking through the folders or using the search box at the top of the Tab Manager panel.

Let me know if this helps.

1 Like

Rory, can you put a note onto the website under the Documents > CAD Files page with the instructions that you just gave in your reply. I’m certain that others have tried to do the same thing and ran into the same problem.

1 Like

You got it:

1 Like

A post was split to a new topic: Trouble controlling FarmBot