FarmBot-Message Broker connection issue

I’m an Italian student from Perugia, working on a local company’s Farmbot.
I have a problem connecting the Farmbot to the Message Broker.
The tool in the Web App shows that all the links are green, except the Farmbot-Message Broker and the Farmduino-Raspberry ones, even though the Farmduino and the Raspberry are properly working and connected with the provided USB cable.
Reading the FarmBot documentation I saw that the issue could be related to the firewall of the company’s wi-fi (but I can’t open the indicated ports because it needs the owner presence and unfortunately he’ll be away for some days), so I repeated the bot’s connection procedure (re-flashing Farmbot os on the sd card and following all the steps of the configurator) using various hotspots from various smartphones with good signal quality.
At this point the Farmbot-Message Broker link (showed in the Web App’s tool) becomes green for some seconds but then it goes back to red repeatedly, while the Farmduino-Raspberry link remains red all the time.
I tried to connect the Raspberry to a monitor via HDMI to see the log, and it shows “the link becomes ready”, then “error -52”, then “the link is not ready”. The status of the link changes for some times between ready and not ready before stopping, I’ll attach a photo of the log. I can’t identify the origin of the problem: is it something in Farmbot or the network?
Thanks in advance for your help.


the issue could be related to the firewall of the company’s wi-fi

This is one of the most common issues we see in new installations, particularly in corporate / school networks.

repeated … using various hotspots from various smartphones with good signal quality.

How was the signal strength and board voltage (see image below)?

is it something in Farmbot or the network?

I have a device on my desk that has been operating on a firewall-free WiFi network for weeks without issue on FBOS 9.0.3. We have not observed any network related problems with this version of FBOS, so my guess is that there is a local issue at play, although we don’t have enough information to know.

  • What version of FBOS are you using?
  • What is you current WiFi level?
  • Which FarmBot model are you using?
  • What is your device email? Please send me this via private message- I can inspect your device logs remotely.

Note to other users who found this message via search: FarmBot has authored an article for IT professionals that may address some questions regarding port usage.

Hi guys,

I work in a school and experienced the same sort of issue. It took an IT person monitoring the connections to the Internet during the configuration process to find the issue. As they explained it to me, the entire network was open and there should have been no reason for the connection to be blocked. However, during the configuration process, farmbot has one device name and then it changes for a split second during the configuration process. That then sets off alarm bells for the firewall / protections that are on the network / ISP as it is something that hackers do (apparently).

You will need to get whoever looks after the network to track the connection during the configuration process, find the name that the device switches to and put that on a list of approved connections. As soon as our guys did that, it worked with no problems. It took 2 months of fiddling with it and the IT guys telling me that there was nothing preventing it from making a connection.

I hope this helps you to connect and get it working correctly.



Hi everyone,
I’d like to report that I solved the problem.
I had the issue with FBOS 9.0.2 but when I switched to the 9.0.3 version everything worked fine: all green links and I could control the bot.
Anyway I used a smartphone’s hotspot as an internet connection source.
When I tried to use the company’s wifi the issue persisted, so 99% the problem is related to the firewall (as said in the documentation) or to the device name switch indicated by @markgregory8.

Hope this topic can be useful for future users.

1 Like

So glad to hear your network problems are fixed, @markgregory8! :tada:

Could you please have your IT staff write me a blurb on how they fixed it? Sepcifically, when you say “change names” are you referring to the device’s hostname? This feedback could greatly help us improve the experience for education/enterprise users running firewalls and other security software.


@RickCarlino has been diligently helping me trouble shoot our school’s device. He forwarded me your post and I will get that to our IT department. Is there anything else you can share about your fix?

Hi Guys,

The firewall had a rule that allowed the traffic from an IP address but the problem was that it was needing a rule for the DNS name. Once the farmbot connected via IP, it then changed to a DNS name that was being blocked by the firewall as it was no longer just the IP address. Once they entered BOTH the DNS name and IP address as exceptions, it worked immediately.

After 2 months of trying to getting it to connect, the moment I saw the solid blue and green lights was a highlight of 2019!

Hope this helps solve the problem :slight_smile:


1 Like

@RickCarlino @markgregory8 Should we be entering a DNS name?

Hi, I’m also having connectivity issues with my Farmbot.

About two months ago, I was making many plantings in the middle of the day with the Farmbot, and then it stopped working. After opening the box, I saw there were some burnout on the Farmduino’s circuit board.

I have replaced both the Farmduino and the Raspberry pi, but am still unable to sync. The errors I am seeing is a ‘red’ connection between the FarmBot and the Message Broker. On occasion I see a red connection between the Farmduino and the Raspberry pi. I also see that the voltage is low (yellow circle).

Any idea what may be the problem and how to proceed?

I am using Farmbot Genesis v1.4
I am connecting to the Farmbot using my cellphone as a mobile hotspot, but previously when using cable wifi I had the same error messages.

I am particularly interested in the red linkage between the Farmbot and the Message Broker and also the reason for the ‘low voltage’ error.

Thank you

Maybe the 24V power supply was also “cooked” ? Worth checking with a DMM at the Farmduino connector.

That’s a good point jsimmonds. I am able to do low-energy operations like taking a photo, turning on and off the water and vacuum, but cannot get it to move in x,y, or z directions.

Following your suggestion, I tried measuring the voltage after the 24V power supply and also where it connects to the Farmduino, but the pins are in too deep and the holes to small for my voltmeter probes to reach them. Perhaps I will try at the motor ends. Thank you for your suggestion.