Farmbot Motors are not running

Please find attached a video which shows our settings and conditions.
I have read all the postings and tried out everything.

I need help in getting the motors to run!

Debjyoti Das - FarmBot Motors are not running.MOV

Hi Djdas,

I noticed that the Z coordinate you gave the farmbot was a positive number. I think by default it is set in the Z axis to move in negative numbers i.e -500 would be 500mm away from the Z axis home position.

I am, however, assuming that you have changed that and that you’re not getting movement on any of the other axis either.

There’s a few things you can try.

  1. Disconnect the motors and measure the current going to them with a multimeter. If the current increases when the command is given to move the farmbot then the motor is probably broken. You could also try increasing the current going to the motors in the web app.
  2. Disconnect the rotary encoders and disable them. That may help you get some movement.
  3. Your farmbot appears to be communicating with the web app so the raspberry pi is fine. Check to see what is happening with the farmduino board. Measure with a multimeter to ensure there is current flowing through the board.

I’m sure there’s lots of other Farmbot users with more experience and better ideas than me. Hope you get it sorted out soon!


I have done ALL the steps as you have mentioned.

I have recorded the settings and the tests with the multimeter. Please see the videos.

Farmbot settings

Multimeter tests

No signals are going to the motors. It’s almost as if some switch has been turned off somewhere and nothing runs anymore!

Please help,


Alright, sadly I can’t see what exactly you measured on the Farmduino but it looks like you tried to measure anything between the pins where the motor gets plugged?

Was already suspecting a faulty board or fuse, but at the end of your first video (at minute 1:17) I’ve noticed that you chose Arduino/RAMPS (Genesis v1.2) in the Firmware dropdown list. This might cause exactly the problems you have, since the pinout for the motor drivers are completely different (according to the documentation). Just change the firmware via dropdown menu to your type of hardware (Genesis 1.4 I guess)

But its a good sign that your board is still working (softwarewise) as it seems to sync properly :slight_smile: