FarmBot OS is not loading

Hello everyone,

I am trying to boot FarmBot without connecting motors (At this moment, I cannot physically access the place), so I want to set up the software. However, I am facing an issue with the OS not loading.

  1. Then my friend brought up an assumption that the Undervoltage was an issue. We tried with an adapter with a 5V voltage, but the software was still not running.
  2. I was keeping in touch with Farmbot support, and they proposed several possible ways to resolve this:
    a) The SD card should be flashed again. So I took another SD card and flashed the image on the new SD card. Then, when I tried to run it, it was still not running.
    b) Try to run it in simulation mode as shown here: Simulating a FarmBot | FarmBot Developer Documentation
    I had my Arduino with me, so I tried that setup and again tried to run the 1.2 version of the software. However, for some reason, it was still not working.
    c) They also asked to send some screenshots from the web application, but it was not running, so RPi created no WiFi network, so it just didn’t make sense to me.
  3. The issue could be with the SD card, so I tried to flash and upload regular RPi OS, and it was running correctly.

I am attaching photo of the log when I tried to load farmbot.

Hi @nzekenov That console output looks Ok.

  • When you flash FarmbotOS onto a new SDHC card, the first boot will enter Configurator mode and start a wireless AP for you.

Have you searched for a local Wi-Fi AP with an ‘open’ SSID similar to farmbot-8dc9 ?

Hi, @jsimmonds

Thank you for your reply. I resolved the issue with not booting OS and not appearing Wi-Fi. Surprisingly, when I tried booting the RPi without any HDMI connections, it booted normally, and the Wi-Fi network appeared. From there, it was pretty straightforward.
However, I configured the Farmbot to connect to my mobile hotspot (on the phone) and noticed that the ping between Farmbot and Message Broker was too high. Therefore, we decided to approach it differently by installing Raspbian on an RPi and sending control signals to the Farmduino.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.