FarmBot stepper motors improvement tips

As using Farmbot, does anyone have face problems that have a short pause when motors acceleration, encoders of the motor always lose steps or motor noise is too loud? Today, using this idea maybe can solve your problems.
The reason causes that problems are the number of motor’s micro-stepper is too low. Farmbot defaults micro-step number is only one so that maybe cause the motor has some shake. The shake can cause the stepper motor to lose steps and make more noise. so you may try to raise the micro-step to 2, which can have a significant improvement. You only need a few simple steps to complete the setup.

  • First of all, you will open your electrical box and find red DIP switches, which above each A4988 driver on the Farmduino. Then turn on the first switch of each DIP switch. Please pay attention to the welding of DIP switch on the Farmduino is reversed!!! So you have to read the number on the Farmduino broad, but no DIP switches.
    Second, you need to go to the web page to modify the parameters. You only need to change the number of MICROSTEPS PER STEP to 2 and keep other parameters are consistent. (Some parameters may be modified automatically. Please make sure that they are compatible with the picture below.)

    That’s all; you can feel the noise of Z-axis reduce, and no longer lose steps.
    BTW: If still have some lose steps, you may try to check the tightness of the belt and the sliding rail movement.
    I hope this helps you. Thanks!
1 Like

DIP Setting:

2 Likes

Thank you very much