Farmbot stops after first event since since update to 14.1.2

Hi there,

since I updated to Farmbot OS 14.1.2, my Farmbot stops after the first event and skips the second one.

Any ideas to what might be wrong?

Thanks in advance and best regards - Dick


Hi @Dick

From your picture of the Sequences panel I couldn’t decide which ones you mean.

Have you tried a fresh manual re-flash of 14.1.2 onto a known good quality SDHC card ?

( This release version seems quite solid so far . . . What’s your bot hardware ? )

sorry, the ones at 6:10 AM … and no, I have not tried a fresh manual re-flash of 14.1.2 but updated via Settings > Farmbot > Farmbot OS … and my bot hardware is Genesis XL …

Hi @Dick sorry to hear about the farm event issues. I will take a look today.

@Dick I don’t see any error events for your device, unfortunately. Although 14.1.2 made no changes to the farm event system, we have been noticing some behavior related to farmevents during the reboot time. Particularly, we’re noticing that some events are skipped if they are the first event after a reboot, which could be the case if your boot recently upgraded (a reboot is required after an upgrade).

Did a hard re-flash solve the issue? We are still actively investigating this one.

@RickCarlino I just pressed the ‘UPDATE TO 14.1.2’ button under Settings / FarmBot. Where can/do I need to reboot my Farmbot? By the way; I now see that there is an update to version 14.1.3 …
Screenshot 2021-06-22 at 19.21.09

@Dick The comment was in reference to @jsimmonds 's comment that suggested performing a “hard reset”. I wanted to know if you had taken his suggestion and if that suggestion has resulted in different behavior.

The reason I ask (and the reason why he suggested it) is that sometimes a hard reset can repair corrupt data on the SD card that might cause the farm event scheduler to fail. Re-flashing the SD card manually is not the same as re-flashing from the web app.

If you are still having farm event issues, I would suggest performing the hard reflash (via Etcher rather than the web app). Instructions can be found here: Advanced Software Troubleshooting | FarmBot Software Documentation

Hi Rick, after the hard refresh and reconfiguring my FarmBot to connect to the internet, this problem is solved.

Just makes me wonder whether to use the ‘UPDATE TO x.x.x’ button next time …

@Dick We have not found a root cause to the issue yet, but we believe it is exacerbated by device reboots that occur around the time that a farm event is supposed to occur. Since a device upgrade requires a system reboot, that may have been a contributing factor. We still don’t have enough information to know for sure and it only occurs to a small subset of users, which makes it difficult for us to isolate.

Setting auto-update to ON and setting your update hour to a low-usage time of day (such as 3 AM) may help in these scenarios.

We are still investigating the root cause and hope to have a fix in place in a future update.

Hi Rick,

I’m not a big fan of auto-updates. When I do a software update manually, can I then do a system reboot as well? And if so, how/where do I do this?

Thanks again!

@Dick There is no need to reboot after a software update, it will do this for you automatically.

If you don’t like to do automatic upgrades, that’s fine, but you must keep in mind that we reserve the right to block devices from connecting to our servers if they run a release that is older than 60 days. This is not to say that you must run auto-updates, it just means that you will need to push the “UPDATE” button at least once every two months. Our reason behind this decision centers around the fact that although each device runs independently, the servers that it uses do not. You can read more about the rationale for our decision in the link provided.

If you live in a region that has winters that are longer than 60 days, you must perform a hard re-flash when you bring your device back online in the spring since the fall version will be deprecated by springtime. Account data is not affected by this policy- all data is backed up on our servers.