FarmbotOS rpi0 without Farmduino

Hi everyone

I’m currently work on a french project in Normandy region about development around the farmbot (plugins) and local network connection abilities.
In order to realize some connectivity tests, and because I’m in another region without physical farmbot, I try to install FarmbotOS (the rpi0 version found here) on a Raspi zero W without having farmduino connected on.
By using HDMI screen connected on rpi0, I can see that OS is running and passed some steps without any problem.
After a while, a warning error about “logging” appear (see attached image), quickly, and then Erlang is stopped. Finally the rpi0 is restarting, again and again …

Do you have any tricks for this problem ? Is it normal that a simple installation (with Etcher) of the image on my SD card (a transcend 8Go) not worked in my case ?

Thanks a lot for your help.
Thomas Berriot

Hi @tberriot

I can’t tell what the problem is based on the information provided, but I would like to offer some alternative ideas if your goal is to simulate a real device.

I did a quick check of an express bot I have on my desk. It was able to boot, but in my case, the device was already configurated with a Farmduino attached- your scenario is slightly different and there may be another factor at play.

If your goal is to simulate a real farmbot, I would like to propose an alternative. The method I will describe below is how we simulate a FarmBot at FarmBot, Inc. The cost of materials is minimal and it is very reliable for testing purposes.

Suplies Needed:

How to set it up:

  • Connect the Arduino to the RPi
  • Create a new account at my.farm.bot. Do not re-use accounts that were previously used for Express devices. It is best to start with a completely new account, since your account might have old (bad) config settings.
  • After registering for an Account, select “FarmBot Genesis v1.2” as your device model.
  • Flash the latest version of FBOS onto the device and continue setup as usual.

How to debug problems:

We do not recomend attaching a display monitor to any FarmBot OS device. Unlike Express devices, FarmBot Genesis can be debugged via a USB TTL cable. This makes it much easier to find problems. For example, you can type RingLogger.next() to see the most recent error logs. Numerous online tutorials will explain how you can accomplish this. Please note that a USB debug cable will not work on Express models.

I hope this helps!

Hi @RickCarlino

Thanks a lot for your help !
So, I understand that it’s mandatory to connect an arduino to get development kit, it sounds logical.
Otherwise, you seems to advise me to go to rpi3 and Genesis installation. Why ? A dev kit with rpi0 and Express install is not possible ? And, if it should be possible, can I connect an arduino MEGA like on rpi3 ?
Finally, there’s no problem to me to follow your instructions, but i’d like to explore every possibility.

Thanks again
Thomas

Hello @tberriot.
One RPi0W device alone can be used to test local network connection abilities.
Make sure that you flash the newest FarmBot OS ( for rpi ) onto a good SDHC card.

If you then need the FBOS running on the RPi0W to boot and stay running, you will need a valid Web App Account somewhere ( the code needs this ) . . can be https://my.farm.bot or locally hosted by you. In your Web App account for the RPi0W you can set hardware firmware to NONE to tell the code that you have no Ar/Farm-duino MCU connected.

I understand that it’s mandatory to connect an arduino to get development kit, it sounds logical.

This is actually not required if you use an RPi3, but highly recommended. I have never tested this on an Rpi0. Additionally, you can set the firmware to “NONE” as @jsimmonds has recommended, but for testing purposes, having an Arduino connected will give you more realistic results and allow you to test sensors and actuators at your desk without using a real FarmBot.

you seems to advise me to go to rpi3 and Genesis installation. Why ?

The simple answer: I know that it will work reliably in “headless” mode, but I can’t say that for the RPi0. FarmBot OS has been simulated by FarmBot employees using the setup I described above for years. It is well tested and reliable when you need to test things like firmware connectivity or general FBOS operations.

The setup you have tried (rpi0) might work, but it has not been tested to the extent that a RPi3 + Arduino MEGA have been tested.

A dev kit with rpi0 and Express install is not possible ?

@jsimmonds appears to think it is. I have never attempted this beyond the quick check I mentioned in the previous message. The last time I tried, I hit some errors.

And, if it should be possible, can I connect an arduino MEGA like on rpi3 ?

Feel free to continue experimenting- this is part of the fun of Open Source! My ability to investigate problems on a headless RPi0 setup is limited since our main priority is helping customers running standard kits, but you can certainly keep trying. If you find that there are too many issues on the RPI0, a more traditional RPI3 + Arduino MEGA setup (listed above) will certainly work as a fallback option. Good luck!

Thanks @jsimmonds & @RickCarlino for your replies !
At this point, I don’t have good result with rpi0 if I follow @jsimmonds instructions.
To go faster, I’m gonna test the Rick recommendation and I will give a feedback soon !
Thanks again
Thomas

1 Like

Hi @tberriot,

Here is my RPi0W running the latest FBOS with no MCU and with Public Key SSH access
( just to show that it all does work :slight_smile: )

I’d go with @RickCarlino’s suggested RPi3B if you need access to Erlang and Linux via a Serial Console if you need to debug IPv4/IPv6 connectivity.

This is the hardware ( running on a 15Ah battery :slight_smile:

3 Likes