Farmware install issues


#1

We have been working on setting up our school Farmbot. We are quickly checking things off our list but the farmware is the newest issue. We cannot get the usb camera to work and tried to reinstall the camera farmware but the reinstall icon is greyed out. We are working with our IT department to ensure that the github is whitelisted but we are still not able to install any farmware to our FB.
image


#2

Hello Rob,

While helping my friend Troy in Sherwood Park AB we had a similar problem. We were able to fix the problem by replacing the USB extension cord from the end of the camera cable to the USB port.

Marc


#3

Thanks Mark. I have tested the camera with and without the adapter on other devices and it works fine. I will still try to replace the adapter though. Where did you get yours?


#4

Hey Rob,

I think we just went to staples but they are definitely available online. You may also try unplugging the USB cables and checking for plastic or debris in the USB ports.

@TroyD Troy these sound like the same symptoms that your unit was having. Could you provide comments and what to check for?


#5

Rob’s camera sounds like its working with or without the USB extension so it might be different.

Replacing USB extension cable can be tricky because of the specific L type plug ending that it needs. I never did find a replacement L style USB plug. Instead I went with the shortest/smallest USB plug end that I could find. I had to unscrew the circuit board, plug in the USB, then screw the circuit board back in, that’s how tight it was!

The symptoms are similar but the short USB extension cable didn’t work with the farmbot or with my laptop.
I don’t have any suggestions for the while farmware update not working. If I think of something I reply again.


#6

@rob.niedermeyer
When you say “We cannot get the usb camera to work”…
Can you add detail to this, please?
What happens when you attempt to take a picture in the stock Farmware? (Farmware tab —> Photos —> Take Photo (green button)
Any log info?